Track 1 auto routing to main

I tried to find of there were other posts about this but wasn’t able to see any, if I missed one please let me know.

I started up ardour yesterday for the first time in a while to record some quick 2 track demos.

I ran into an issue where upon opening the session, even after it had been saved, the output from channel 1 of my interface would be routed both track 1’s input in the software but also to the main bus input, causing a doubling. I would disconnect it, save the session, close and go back in, and once again, the audio input would still be connected to the main bus as well as track 1.

Is there a checkbox I’m missing that makes this happen? I have it set to hardware monitoring.

note: I haven’t had a chance to update to 3.5.403 but ill be doing it soon, just haven’t gotten around to it.