timestretch a beat sample (region) to fit project tempo?

I have been trying to squash (speed up) a beat sample (about 2 beats long/half a bar) to about 97% of its original length so it aligns with the Ardour project tempo.

When I use the region stretch/squash tool, the resulting region is shorter than I expect. I have tried turning snap-to on and off to no avail.

Alternatively is it possible to stretch a sample without using a preserve-pitch option - i.e. just resample - and would this allow me to resize it precisely?

I ended up resampling it by the appropriate amount in Audacity then reimporting, but I figure I’m missing something, surely this can be done directly in Ardour with ease?


a long standing bug …

… but its not in ardour itself, but in libSoundTouch that we use for stretching. It will not be fixed at any time in the foreseeable future - we are hoping that a new timestretching library from the primary author of Rosegarden will help here.

Ah yes. Soon, honest! And it will do sample-accurate time stretching.


Cheers, looking forward to it, though keep in mind the possibility of “no stretch just resample” or using alternative libs in future…


any news here?
i’ve just run into the same problem, although on a larger time scale - trying to sync a dat with a video camera soundtrack. the stretch i need is about 2 frames in half an hour, and getting it right with soundtouch is all but impossible.
cannam: got a beer address?

looks like http://www.breakfastquay.com/rubberband/ is here. is this on the radar for inclusion into ardour?

I think it should be in the 2.0-ongoing Ardour SVN branch now, although I think the GUI hasn’t yet been updated to offer the right set of processing options for it. And it only gets built if the Vamp SDK libraries are found at configure time (http://www.vamp-plugins.org/).


yes, it’s included in the ongoing trunk, but as cannam said the gui is not updated for all the rubberband features, but the time stretch works now sample accurate.

Which additional features do we have to expect when rubberband is finally included in the GUI?

lovely. i’m looking forward to checking it out after christmas.

Any hints on how to get this into a build? I’m running the 2.1 release that I built myself but I’m running into the same issue with timestretching and I’d like to get this working. Is it just a case of downloading the vamp plugin SDK? What do I do with it once I’ve downloaded it?

DrG, you can just wait for 2.2 that will be released probably monday.
The other option is to check out the development branch, 2.0-ongoing. However, this involves compiling the software yourself, and can be quite tricky if you’re not used to it.

Thanks, I’ve built from the 2.0-ongoing branch and it is now working perfectly. It’s one of the best-sounding timestretchers I’ve used.