Testers wanted for Debian -rt9 highmem (PAE) Kernel


Here is a link to an -rt Kernel for Debian users. It is i686 patched with the -rt9 patch and built with highmem and PAE options for those with more than 4 gig of RAM up to a maximum of 64gig. Please note the “64” in the Kernel filename denotes the Maximum memory handling and has nothing to do with 64bit.

The link has the image, headers, and ivtv modules which you only need to install if you have a Hauppage TV Card.

This is working well on my desktop and laptop but I’m sharing it with no guarantees and for users to try at their own risk.

If you do try it PLEASE post back feedback as this is the likely Kernel for A/V Linux 2.0 to be released very soon.


Enjoy! -GLEN


Thanks Philip I appreciate that, My comments in another post about this subject were not intended for anyone specifically…I just found it to be one of those ironic human nature deals yadig?

I hit a brick wall awhile back with Linux/Ardour also… like you said the show must go on, Enjoy and learn PT8 for now and when curiosity gets the better of you again in a while probably Ardour and Linux hardware support will have progressed and improved to a point where your new hardware is supported to your satisfaction,

In the meantime forget about platforms…except maybe platform shoes and Rock OUT!

Just wanted to add a comment concerning the rt kernels you worked hard on.

I have not had a chance to test or even download for that matter.

I appreciate the adding of PAE and look forward to using AV 2.0 on a spare machine when I get the time to work with it.

Recent hardware to distro incompatibility issues forced me back to windows running PT8. The show must go on.

If any of you reading this have tested these kernels how about a little feedback !?!?

Thanks Glen

Officiall debian dev are also busy with an RT kernel, maybe you can offer some assistance



That’s very flattering but I’m sure the Debian devs know more about kernel building and hacking than I ever will!


I’m comparing this kernel to 2.6.29-rt1 and so far I get better wireless (laptop Intel 3945 IPW) and am able to build Virtualbox modules with 2.6.29-rt1 and not with this latest As far as Audio performance goes they are about equal in my tests so far. The whole pace of recent Kernel development seems absurd, where’s the fire?

The Virtualbox Issue is due to the newest version of Virtualbox 2.2.XX
Wireless is likely firmware related and is only with IPW3945


Well since no one else wants to comment (even though there have been hundreds of downloads). I will share my findings so people at least will know what to download (:b).

In my own tests with 4 Gig of RAM I have found 2.6.29 -rt1 to be head and shoulders above the two other highmem -rt kernels ( and With an M-Audio 1010LT I can run 256 fpp/2 buffers without xruns and the other 2 Kernels are requiring 512fpp/2buffers and still showing occasional xruns.

Whether this is due to the highmem support I can’t say for certain.

hey GMaq, I am not talking about your compiled kernels but I have been using the 2.6.29 serie for a while. I would say that there’s hardly any difference for the h/w I am using.

I have Intel h/w, no wireless, no fancy GPU. The only fancy thing about my h/w is the RME HDSP system and the SVDO extension to the intel IGP so that I can work with two screens instead of one.

This said, I am using ATM (was too lazy to update) with bigmem enabled (have 4G). I am also using jack2 svn. I have amazing system performances at all latencies. I cannot go further down than 64 frames, n period 2 with the PCI HDSP (I would need the RME PCIexpress upgrade for that). But for what I am doing, this is way low in latency (0.7ms inbound, 1.3ms round-trip). This is great when I want to play live (piano software or guitar software effects).

I would expect glitch free operation at a lower buffer size with your M-Audio but factors are plenty that can annoy the audio.


Thanks that’s good info to know, At least with all kernels there are no random lockups and stuff like that, I don’t exhaustively tweak my systems for -rt, mainly the PAM Hack and an -rt Kernel so the difference I was showing was with the same setup with different kernels without further tweaking. Obviously you know your hardware inside and out!

Having said that the latest Kernel I have ( does work fabulously with my laptop Intel HDA in full duplex at 512fpp, although it’s had ALSA support with many Kernels I’ve never been able to get it to run with Full Duplex before and certainly not without maxxing the fpp to 4096. So that’s progress I guess, I’m still a little baffled with the performance drop using the 1010LT though?!

Hello Glen,

thank you for providing a RT-kernel for Debian!

Today I installed your latest .deb from your link:


My starting point was an (dist-upgraded) actual Debian/testing aka squeeze with Debian kernel 2.6.29-2 with kde4 on an intel atom eeebox. I needed a while to find out, that some additional entries in /etc/security/limits.conf are needed for an RT user, something like …
@audio - memlock 512000
@audio - rtprio 99
@audio - nice -10

End of file

which seems not to be well documented in the most wikis, but can be found in lots of forum posts.
I have no problems with your kernel in qjackctl so far and can play the e-piano MrRay73.dll without any noticable latency. - But I have to learn a little more about the tweak-options of jackd and RT.

I needed a RT-kernel, because I want to play some of the marvellous plugins with a midi-keyboard in realtime. One or two years ago, I compiled a RT-kernel on an PIII 800MHz Laptop with success, but it was near the edge of its power and too much of a hassle to keep it all running after updates. But now with the new “netbooks” it becomes interesting for me again. A dream would be, to see a realtime-kernel in the Debian one day. Thanks for your steps in this direction!

kind regards

Thanks very much, I appreciate the feedback, Glad it’s working for you.

Hey Glen,

Just a quick note to let you know I tried AVLinux 2.0 today. I went for the “live” experience, had no troubles except for xruns at low-latency values in QJackCtl. I assumed they occurred because I was running from a live session and would probably disappear with an installed system. Anyway, it looks good and I’m inspired to test further. Nice work !




Thanks for taking the time to check it out. The low-latency x-run issue is because the LiveCD runs the stock Debian kernel. Since AV Linux is for Audio and Video users I opted to run a stock Kernel and have put optional -rt Kernel packages in the Users Home in the “Audio-Extras” Folder. Unless you run more than 4 Gig of RAM I strongly suggest using 2.6.29-rt1, It is very fast and stable in my own experience and from user feedback I’ve been receiving. However both Kernels work well depending on your hardware.

I would appreciate any feedback from our local esteemed Linux Audio Guru!

If you or anyone else is interested I have a new ISO on the way (next week) featuring XFCE and LXDE both as Desktop Environments, Updated linuxDSP plugins , Latest Qtractor (0.4.2) Rubberband (1.3) and Sooperlooper (1.6.13). Minor tweaks and Software substitutions. Current users don’t panic, this is a freshened up ISO not a new version, the above mentioned packages will be separately available as well.

Check the News Link here: http://www.bandshed.net/News.html

I’d like to thank Paul for patiently allowing me to post here, most of my site traffic come from this forum and I haven’t the time or dire need for an AV Linux forum yet. However I am mindful that it is somewhat of an imposition to be here when I am “Ardour Related” but not “Ardour Specific”.

I’d like to encourage AV Linux users to bookmark and check the News link above as I am making an effort to not wear out my welcome here.

Thanks -GLEN

I noticed some strange behavior when using your 2.6.29-rt1-rt kernel. At random times, my network interface will stop listening for three minutes, and then come back. During this time it can ping any address (and doing so causes it to begin listening again) but if I try to reach it from work or from another room in the house where I can’t simply reach over and type “ping” into a terminal I’m out of luck for three minutes. I rebooted with the stock Debian kernel and haven’t had this problem since. I know the argument–a real DAW doesn’t need to be connected to the internet–but that’s how I roll. Unfortunately, I don’t have any useful information for debugging because I don’t see anything specifically related to the timeouts in my log files. Maybe I’m not looking in the right places.


That is weird, Unfortunately I can’t reproduce it, As far as a DAW not being connected to the net, we Linux users have a lot less to fear, I always thought that was aimed at Windows users for malware purposes. Have you tried any of the newer highmem Kernels? Just because they are highmem doesn’t mean they won’t run on systems with less than 4 gig of RAM. I also have an updated rebuilt 2.6.29-rt1-avlinux that will ship with the next ISO, perhaps I’ll put it up separately… would you be willing to try it and let me know if it does the same thing?

Thanks for the feedback, I haven’t had any other reports on this issue so I appreciate you letting me know.

I think the argument against connecting a DAW to the internet is that ideally there shouldn’t be any additional processes running that are not related to audio or to the basic operation of the computer. I might be willing to test the new kernel–I recently reinstalled the latest version of Ubuntu on my workstation and it’s incredibly unstable now. Anything would be an improvement at this point.