Tempo change and midi in Ardour 7.3

I’m using Ardour 7.3
I wrote 2 bars of 1/4 notes using the step entry keyboard.
Then i changed the tempo from the default 120 to 100bpm
Now the region is shorter than 2 bars
Is this the correct behaviour? I thought v7 made midi regions follow tempo changes, or did I misunderstand?

How was the playback? Did it play back in less than two bars? Or it did play back as expected and the audio and the visual were out of sync?

I’ve just experienced problems with an imported MIDI file not conforming to the changing tempi in the new session. However, the notes play back exactly as expected so what I see and what I hear is out of sync.

It plays back out of time as well as appearing out of time

Works fine here, in Ardour 7.3-65-gf8557cc00f

That’s great. Maybe @Paul has fixed it.
I was just about to share an audio file showing the interesting musical effect I was getting!
Is there a deb package of this version available?
Many thanks

Unfortunately not; I compiled it myself.

I’m assuming that question is pointed toward me… I don’t really package Ardour, I make Debs out of the official Ardour bundle to put on AV Linux releases and if there is something really amiss within a short time of a release I might provide an updated nightly fix but the idea is for me to give you a good working system with a full supported version of Ardour (which you can actually thank @paul for) and if you like it moving forward I’m hoping to encourage people become purchasers or subscribers to the Ardour project. Ardour is not free, Ardour from Distribution packagers is not supported, I’m a subscriber myself and I update Ardour on my own system as nightly fixes or new releases come out so I’m not suggesting other people do anything different.

Many thanks Glen
I was asking @peder, as he said the Ardour version he has works properly.
I am an Ardour purchaser.
Apart from the downloads on the Ardour site, I don’t know where the various
different types of Ardour package come from.
If there is a debian package of a build of Ardour 7.3 which solves the
issue I am sharing with the forum, I would like to get it.

Encouraged by @peder I downloaded and installed nightly build, Ardour_7.3.168_dbg.
I tried the same process, but alas, the timing problem remains.
Next I tried midi input, which I then quantized. It followed tempo changes perfectly.
I made a further track and performed step entry, which I then quantized. Again, this did not follow the time.
@paul, is there anything in the preferences that may control or influence the behaviour of the step entry function?
Many thanks

On a further note, in the step entry track, I’ve just drawn a 1 bar region with the pencil, then drawn eighth notes. This follows the tempo change perfectly. (the second big region in the pic)

On the positive side, at least I know a way of entering patterns that will follow tempo changes!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.