Tascam US-1800 16X4 Audio/MIDI Interface

I am looking at buying a Tascam US-1800 16X4 Audio/MIDI Interface - I see that it is unsupported on Linux as of a couple years ago. I am wondering if anyone had gotten it to work. Specifically I am running Ardour on Linux Mint 17. THANKS to EVERYONE WORKING ON THIS PROJECT ESPECIALLY PALL!

Sorry ‘PAUL’ typo

Can’t speak for Linux, or I guess the 16x4 either, but the 16x8 works well on both Mac and Windows. If its unsupported, I would be hesitant regardless. The one thing I have learned embarking on this journey is how tightly integrated and fussy hardware can be in having a reliable recording rig.

Can’t speak to that specific model, but I’ve had luck with the US-2x2 on both Linux and Mac with Ardour.

If alsa does not have a working driver for the device then there is no way of getting it to work. Save yourself the trouble and steer clear of unsupported devices.

If you take the risk and buy an unsupported device you will lose countless hours hopelessly trying to get it to work and then in the end you will sell it and buy a supported one :slight_smile:

Although I have no personal experience with it, I highly doubt the Tascam US-1800 will work in Linux. It is not class compliant, so unless an ALSA developer has written a driver specifically for it, it won’t function properly. I don’t see anything on alsa-project.org to suggest this has been completed. I second what others have said and recommend purchasing a device that is known to work.

My Tascam US16X08 works pretty well on my UbuntuStudio 16.04 / Ardour 4/5 with out-of-the-box generic alsa driver.
Nevertheless I’ve patched the snd-usb-audio kernel driver (https://github.com/onkelDead/tascam-driver-patch) to get access to the build-in compressor and equalizer, which are supported on Windows and Mac only.

Thank you for the replies. Anyone have any recommendations on a 8 channel I/O. Something not latest version that I can pick up used. Preferably know to work well with Linux based systems.
I know this site has few recommendations but they all seem like older models. Is there a slightly more updated list of working I/O boxes.
Thanks everyone!

What are you going to use the device for ? If you don’t need zero latency monitoring then Presonus 1818VSL might be an option. Note that it has a low latency hardware mixer that does not work on Linux. This is bad if you do overdubbing, but doesn’t matter if you just record band rehersals and don’t record any tracks over after the fact. I own this device.

Another option with zero latency monitoring is Behringer UMC 1820. This device has its drawbacks, like the famous Behringer build quality / reliability that are not the best :slight_smile: I had to return the first device I bought, the second one I got worked fine.

One device I almost bought was M-Audio M-Track Eight. Its has zero latency monitoring. The manufactures says it is USB Class Compliant so it should work with Linux:


I am able to use my Ubuntu 18.4 Studio along with Ardour and Tascam US 20 20 with ALSA driver.
The downlside is that JACK will not work at the same time in Ardour. It is either one or the other. So My Steinberg UR22 mkii is not recognised by Ardour anymore at the same time as the US2020.
Additionaly, the US 20 20 will only work at USB2.0, with its respective cable only. But it sees 20 captures. Fair enough.

What audio/MIDI backend are you telling Ardour to use? Both its own ALSA driver and JACK require exclusive device access, so if you want to share the device between many programs, then you need to use JACK. If you don’t need other programs using the device, then we recommend you use Ardour’s own ALSA driver for audio and MIDI.

Thanks. That is exactly the point. Either ALSA or Jack. I can live with it, but it seems to me my other interface Steinberg UR22 mkii is only recognised with Jack. I wrote myself a little bash script,

qjackctl &
sleep 5s
a2jmidid -e &
sleep 5s
ardour5 &

So now I do not run that script not even Jack,. Now I have Ardour start ALSA driver. My tascam works with USB2 cable like that, but now I gave up my UR22.
Additionally, it would be nice to have Ardour working with USB3. You certainly know that it makes a good difference in latency. It would be like thunderbolt, something like that. I still haven’t tried the ADAT, because I do not have that in my PC.
After 2 decades using Linux everyone can now hear I am setting up a Windows 10 machine in order to use USB3. It’s a shame, I know.

Arrays of Cheers!

Ardour plays no part in this. It uses the operating system provided drivers for all I/O. So in this case Linux (the kernel) needs to support it for the device/chipset. What USB3-only MIDI device do you want to connect?

I’m also really surprised that USB class 2/3 makes a significant difference on systemic latency for the case at hand, even more so since a 3 byte MIDI message on a physical wire takes 1ms to transmit.

Does anybody know more, or where to look for a clever beginner’s education, about the technical details on why MIDI doesn’t work on USB3? As an underemployed freelance programmer who is also a musician who exclusively uses Linux, I may be in a position to help. I committed to some work on SuperCollider not too long ago, but as a US-20x20 owner this stuff is also high on my list.

If that problem turns out too complex, or if mainline kernel development will get around to it anyway, I’m also super interested in porting/expanding upon the work at https://github.com/onkelDead for the US-20x20. (The driver portion of that work also appears to have been included in the kernel.) Controlling the onboard DSP from my workstation would rule. I’m running sound at live events around town, and would like to offload the basic EQ and compression to the device.

Consider this post a request for light mentorship from anybody more seasoned with low-level OSS pro audio development than I. :slight_smile:

Maybe you mean ALSA? Open Sound System on linux is basically dead

In the manual, Page 3, in the Introduction says it communicates on USB 3.0 close to the top, but farther down says: “Supports USB Audio Class 2.0”. So for audio/MIDI it should be used as a USB2.0 device. There is only one problem, the settings dialog requires separate software which only works on windows or mac. From reading the online faqs it appears it is not even possible to set SR without this glob. So ya the drivers on the github site you mention are your best bet. The device should work on Linux but any of the internal DSP would not be accessible with out them. That doesn’t really matter though as the gain knobs are on the outside and the internal DSP is not something I would trust as anything more that a selling gimmick.

To be honest, my old (old old old) Delta66 (ICE1712 chipset) has a zero latency monitor mixer on board but I never use it even though there is a very nice Linux applet to set it up. An external mixer is so much easier. Though I guess if you want to use the device as a live mixer, being able to control the whole thing might be useful.

Oh no I meant “Open Source Software”, dunno if that acronym is commonly recognized.

Yo, thanks!!

So I’m currently running sound at an event with Ardour, JACK, and plugins, got a nice MIDI controller for EQ/effects, and my rig isn’t breaking a sweat. I don’t suppose I’d ever break 440 MB/second or whatever USB 2 does, so going without USB3 is fine too. Between that and the fact that you mention that the onboard stuff is probably not super awesome anyhow, maybe I don’t need to go do all that work.


I’m still curious about how to sniff out how to talk to the device. I emailed the author of that code asking them how they did their research.

Thanks again!

OSS means open source software… except when talking about audio device kernel drivers for linux or BSD. OSS (Open Sound System) was the default sound system on Linux in early years and still is the choice in BSD so far as I know. Many Linux Audio applications still offer OSS as a choice for Audio input and output as well. So while never used, it has not quite died. This makes the use of OSS in this context ambiguous. Also the O in OSS audio drivers can be misleading as (at least when Linux was using it) it was not fully open. There was a commercial version as well if one wanted the latest drivers for the newest audio devices.

1 Like

Wow, this brings back memories. I remember having to buy the OSS commercial version in order to get my sound card to work with Linux on my laptop, back in 2001. Not fun, I’m happy ALSA is a thing.