Tascam US-16x08 gtk again

The other thread has been closed so I have to start a new one …

Ubuntu 20.04 here, I tried to follow the installation procedure for Unkle Dead’s tascam-gtk Github thing. DLed the file, unzipped it (directly in the Downloads dir), ran the “build-essential” package.

“./configure” tells me that no package “liblo” has been found. “apt install liblo” was unsuccessful of course. Searched it and found something called “liblo7” so I tried that but unfortunately, this was not what was needed.

First question, do I have to uninstall “liblo7”? And, why is there no “liblo” to be found?

This is a first for me, have never compiled anything before. Every helping hand appreciated with gratitude!

It’s liblo-dev you need to install (although having liblo7 is not a problem). Most compilation dependency packages end with -dev (ubuntu - What do the *-dev packages in the Linux package repositories actually contain? - Stack Overflow)

Thank you! Now it’s “gtkmm-3.0” he’s bickering about … sorry, but I thought installing the build essential package would cover all this. If I go “install gtkmm-3.0” (with or without -dev) I get “missing destination file operand” … now what’s this?

I hate to be a nuisance to anyone so if there is anything I should read please tell me where to find it

Build-Essential is just the VERY basic building blocks needed to compile software in general. What you are now working on are all the libraries that used build essential to compile, that the software is built upon and requires in order to build the software.

 Seablade

OK Thanks seablade. again, sorry to have all these questions that to you seem stupid but how do I install gtkmm-3.0 and everything else that this is going to ask of me?

ok ok I’m sorry now I went with sudo apt-get install and now I have gtkmm3.0 and ./configure finishes without error. My screen is full of magic letters absolutely incomprehensible … and it’s here!
Thanks for your help everybody and so sorry to have taken up your time … we all know what you gurus like to do in your spare time (oops this is from another forum) Problem solved! This Tascam takes up about half a mile of screen in Alsamixer so it’s very convenient to have this OnkelDead thing. I’m happy now