TASCAM US-122 and Ardour5 / JACK

I have a problem with my TASCAM US-122 audio/MIDI interface and Ardour5 with or without JACK running. FYI, this post started as a comment on this Ardour forum thread here >>> https://community.ardour.org/node/15551 <<< but I though I’d expand it a bit in this new post. I have also posted more or less the same question here >>> https://linuxmusicians.com/viewtopic.php?f=6&t=18866 <<<.

I’m using Ubuntu Studio 18.04 on a DELL E6230 with a TASCAM US-122 audio/midi interface.

I’ve followed this guide >>> https://help.ubuntu.com/community/TASCAM_US-122 <<< to install my US-122 up to and including step 7 (sudo usx2yloader) and the US-122 lights up as it should. Using Ardour5 and QjackCtl I can record / monitor / process live audio and midi via the US-122 using Ardour 5, no problems, (I’m using a fully wired 5-pin MIDI cable between my controller keyboard and the US-122).

The is little problem that I cannot seem to solve though…

My startup sequence:

  • Power up laptop, login etc
  • Plug in the US-122
  • Go into a Terminal and run the command ‘sudo usx2yloader’, the US-122 lights up
  • Run QjackCtl then start JACK with the US-122 selected as the Interface, MIDI as raw
  • Use Ardour, record audio, monitor audio, playback audio, record midi whilst the plugin generates tones from the midi notes etc…

So now I want to quit my session and I close down Ardour, JACK is still running at this point. I stop JACK and the whole system freezes. Not even ctrl-alt-F1 works. I have to force my laptop off, and when it boots back up again some of my preferences like the Firefox bookmarks toolbar is not enabled etc.

If I action a shutdown instead, when the OS tries to shutdown JACK it freezes again. This also happens if I pull the USB plug of the US-122 when JACK is running.

If instead I choose ALSA instead of JACK in the Ardour Audio System setting and the US-122 interface in the Audio Driver setting, everything is fine until I click the Start button to the right of the Audio System. The dialog box disappears and the Ardour loading logo appears and again the system freezes completely.

I do have windows 7 and Reaper installed as a dual boot on the same PC and there are no problems when I use that boot option.

I was just wondering if anyone else has had similar freezing problems with this interface, or is there some kind of workaround?


I retried my setup without using JACK, only Ardour directly with ALSA and the US-122, without success…

Test sequence…

  • Boot up PC and login
  • Plug in the US-122
  • Open a Terminal and run the command ‘sudo usx2yloader’, the US-122 LEDs light up.
  • Start Ardour with a New Session
  • On the Audio / MIDI setup screen the I set the Audio System to ‘ALSA’. The Input Device is already set to ‘HDA Intel PCH’. The OS is running with no problems at this point. Window grab here >> http://poqasoft.com/poqapics/Ardour-test-pic-1.png <<.
  • I use the drop-down Input Device box to display ‘TASCAM US-X2Y’. Before I selected this option I took a window grab here >> http://poqasoft.com/poqapics/Ardour-test-pic-2.png <<<.
  • Immediately after selecting the Input Device as ‘TASCAM US-X2Y’, the lights on the US-122 go out and the system freezes.

I had the same problem with Ubuntu Studio 18.04 but at least AVLinux doesn’t crash when I stop JACK (when using JACK with Ardour).

I tried a different way, same as above but I chose ALSA and the Input Device as the default ‘HDA Intel PCH’ then Start audio device - no problems. Then Ardour started up and I selected Window > Audio/MIDI Setup > ‘Stop’ Audio System.

As soon as I changed the Input Device to ‘TASCAM US-X2Y’… instant crash. I didn’t even select Start. Strangely, the US-122 LEDs stayed lit this time!

I’m quite happy using Ardour with JACK, and using ALSA directly within Ardour would be cool but I think it’s just not going to happen on my setup.

No worries! :slight_smile:

Unless you need to exchange audio or MIDI with other applications, we generally reocmmend that you use Ardour’s ALSA audio/MIDI backend. If your comfortable with JACK, feel free to keep using it, but there’s no benefit to it without inter-application communication and some complexities.

Hi Paul,
I tried a live USB iso-tester of 64bit AVLinux but I had trouble installing the ALSA firmware (couldn’t get root privileges). So I deleted my Ubuntu Studio partition and did a full install of 64bit AVLinux. From there I was able to install the ALSA firmware and US-122 firmware. When I loaded in the ALSA firmware for the first time I did get a crash, but after that it worked fine !?!?

I can now login to AVLinux then issue the ‘sudo usx2yloader’ command and the US-122 lights up. Then I can start JACK then Ardour using JACK as the audio subsystem, record audio and midi with low latency and also quit Ardour then JACK with no system crashes or freezing :slight_smile: .

If I try to restart JACK though, for e.g. to change buffer / sample rate settings, then the US-122 will not restart and JACK cannot find the US-122. Even ‘sudo usx2yloader’ fails to find the US-122 again, that is, until I reboot.

So now my workflow is:

  • Boot the PC and login to AVLinux
  • Issue the ‘sudo usx2yloader’ command - the US-122 lights up.
  • Start JACK.
  • Start Ardour with JACK as the audio subsystem
  • Record audio / midi / monitor / playback
  • Quit Ardour then JACK,
  • Do other stuff…

If I need to get back into Ardour or anything US-122 or JACK related I have to reboot, so I tend to leave JACK running until I have to shutdown / reboot for any reason.

It’s not perfect, but I’m happy with this setup, at least it works reliably and I don’t have to reboot into Windows to make this interface work.

Cheers Paul!

Hi Paul,
Thank you for your suggestion, I’m downloading AVLinux right now and I’ll report back in due course.


This sounds almost certainly like a bug in the device driver for this device on your Linux distribution. You could test this by downloading AVLinux to a USB stick, and booting from that to see if behaves in the same way (that will have JACK, Ardour etc. all preinstalled).