Tape mode not working - what am I missing?

Hi there!

I have installed Ardour 3.5.380 on elementary OS “luna”. Tape mode isn’t working, that is, it’s NOT destructive, but behaves just like normal mode: recording multiple regions per track. I prefer tape mode over normal mode, I used it on previous versions of Ardour. Is this a new (or known) bug, or am I missing something?

Does anybody experience the same, does anybody has a hint or trick for me?

I would appreciate it very much.

Thank you!

When I add a new audio track (set to “tape mode”) it gives me the following error:

[WARNING]: tempo map asked for BBT time at frame -1

If I add a “normal mode” track it doesn’t give me any error. What does that mean?
Anyway, something odd is going on with the tape mode…

I don’t use a low-latency optimized kernel, nor do I have “real time” checked in jack…


Tape (destructive) mode has been broken in Ardour 3.x for some considerable time. I can’t tell you when it will be fixed.

Thank you!

Oh, that’s sad news! But I have to admit, apart from this matter, I enjoy Ardour3 very much!
So, how do you guys “live” with clustering your drives with unused regions/clips? Or what workflows do you have?
I mean, how easy was it back in the days (on tape)… Now it takes some extra effort to clean-up a session. It cannot be done within the session. I have to “clean” it, close it, reopen it, flush the wastebasket - and, delete the files in the “dead files” folder.

Is there an other way, to keep my Ardour-session clean and neat?

When I’m working on a song/tune/composition I NEVER want to deal with “old”, “deleted” soundfiles. I don’t really like the concept of overwritten data to get stored somewhere. I want to overwrite it, that’s why I’m doing it.

So, now that the destructive mode isn’t an option - how would you setup your session, given, that your goal is to produce as little
waste as possible?

I appreciate any tips and hints.

I just delete the regions before starting a new take. The way reginos are at the moment recording multiple takes ontop of each other ends up a mess, but its usefull having non destructifve recording when 2 regions need to overlap somewhere.

thats the simplest way to do it, delete the last before recording again, bit of a pain but it stops a mess of layers ontop of layers

Thank you!

I go with your suggestion - or, re-install Ardour2, just for the projects where I’m in real need of destructive recording.
When things has to be “fast”, there is no time for dealing with things other then music. Or let’s say, I’m tired of computer-related stuff during recordings… I go with anything that keeps me from touching a mouse and starring at the screen.
I’ll now try to come up with some puredata-patches (osc) that could ease the struggle I’m having. Let’s say: A button dedicated for recording, another one for recording and previously delete the last recording etc. I’ll let you know.

Thanks again!