Tap Source is set to "Tap Tempo" but can't be changed to midi

Using Ardour 7.3.0, the Tap Source is set to “Tap Tempo”, and is grayed out (it’s a bit hard to see it’s grayed out and non-selectable), and can’t be changed. So it’s not allowing the midi keyboard to be used to set the tempo. The Tap Tempo does work when I repeatedly click the “Tap Tempo” button, and the keyboard (Novation Launchkey Mini) does record and does play fine on a midi track in this same session file. Running Linux Mint 20.3 Una, and Linux kernel 5.4.0-144-generic.

Any ideas on what creative incompetence I’ve achieved? Thanks!

I think you have to set tap source to “MIDI input 1 (or 2)”, and in preferences set your kbd to the same input (active it first)
have fun!

Thanks for your response. I can’t select the tap source because it’s grayed out even though my keyboard is working as a midi input. What is kbd?

you’re not so far if you can REC on a track :wink:
have you tried, in MIDI connections window, to patch your kbd, which stands for keyboard, to the MIDI playback 1?

have you launched Ardour with JACK and ALSA as engines?
and do you type a2jmidid -e in a terminal?
do you find your hard device in the preferences/control surfaces list?

That would mean that Ardour detects no physical MIDI sources.

How is your MIDI keyboard connected to Ardour. Do you use JACK or Ardour/ALSA (Ardour-Menu > Window > Audio/MIDI Setup)?

To list physical sources, you can open Ardour-menu > Window > Scripting, then paste the following code and press “Run”

_, t = Session:engine ():get_backend_ports ("", ARDOUR.DataType.midi (),ARDOUR.PortFlags.IsOutput | ARDOUR.PortFlags.IsPhysical, C.StringVector ())
for n in t[4]:iter() do
  print (n)

Here, one port is listed:

Thanks for your reply.

I use ALSA. Have never tried JACK.

I ran the script. Looks similar to the example you sent. Does this mean Ardour sees the midi keyboard?

Audi/MIDI setup:

From the terminal, here’s the output of lsusb. The Novation keyboard is plugged into the Scarlett 4i4.

It’s strange (at least to me) that the MIDI keyboard can be used to record a track, but still the option for “Tap Tempo” is grayed out as if Ardour can’t see the midi.

Thanks again! I posted some info about the setup etc. I don’t run JACK.

The strange thing is I can record with the midi keyboard, but at least in the Tap Tempo panel, it looks like it can’t see the midi keyboard.

Here’s the output from running a2jmidid -e in a terminal. My noob interpretation is that it figured out I’m not using JACK.

JACK MIDI <-> ALSA sequencer MIDI bridge, version 9 built on Wed Dec 31 19:00:00 1969
Copyright 2006,2007 Dmitry S. Baikov
Copyright 2007,2008,2009,2011,2012 Nedko Arnaudov

Bridge starting…
Using JACK server ‘default’
Hardware ports will be exported.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
ERROR: a2j_jack_client_create: Cannot create jack client
ERROR: a2j_start: a2j_new() failed.

I suspected that you perhaps use JACK (or Pipewire) and the port-meta-data does not include “physical”. But that is not the case.

This should work, and the port show up in the Tap-Tempo dialog.

PS. on modern systems “ALSA Sequencer” is preferable to “ALSA raw devices” in the Audio/MIDI Setup dialog.

Here’s some more interesting info. I connected a Nektar Impact GX1 keyboard directly into my laptop USB port (not into the Scarlett), rebooted Ardour, and then I was able to use Tap Tempo for the Nektar keyboard, but still had no option to use the Novation keyboard to set the tempo.

Running the same script as before:


The Nektar shows up in the Tap Tempo panel, but the Scarlett/Novation do not.
conex and edit tempo 12-46-28

Results from lsusb:
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 5986:2115 Acer, Inc Integrated Camera
Bus 001 Device 003: ID 8087:0a2a Intel Corp.
Bus 001 Device 005: ID 2467:2034 Nektar Impact GX61
Bus 001 Device 002: ID 1235:8212 Focusrite-Novation Scarlett 4i4 USB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Also re: PS. on modern systems “ALSA Sequencer” is preferable to “ALSA raw devices” in the Audio/MIDI Setup dialog.

Thanks for the info on that. I had to select Pulse Audio and then go back to ALSA for the option of ALSA sequencer to show up. Then I changed it as you suggested. Didn’t seem to make a difference with this, but I changed it based on your recommendation.

Now the Novation Launchkey MIDI keyboard directly into the laptop via a USB A to USB B cable, and is simultaneously plugged into the Scarlett (Launchkey MIDI out via a mini MIDI cable as input into the Scarlett as it was before).

Now the Tap Tempo shows the Novation, but not the Scarlett. I can use the Novation to set the tempo, just as I could with the Nektar.

I assumed the Tap Tempo would be able to be set via the Scarlett that would show up in the Tap Tempo dialog box. My conclusion is to keep the Launchkey connected as is, and that I don’t understand any of this midi hardware (or I/O generally) well enough to really understand what I’m doing. :confused:

Thank you for your help and suggestions, and for creating and working on such a fantastic FOSS DAW.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.