System crash / Ardour files corrupted?

hi everybody,

my system just froze while i was working on a rosegarden/ardour project. after rebooting, i can’t load the ardour project file - neither by double clicking nor from inside ardour. opening the project causes ardour to crash/exit immediately.

i ran ardour from the command line to get a verbose output: the error message is simply “Segmentation fault”.

a former snapshot can’t be opened either, while opening a different project is loading as usual.

i didn’t make any backups beacuse i thought the snapshots would do - appearantly, they don’t. are there any autosave-backups? or can i repair the *.ardour-file anyhow? or isn’t the file damaged at all and i am having a hardware-/software-problem?



Which version of ardour is this? If this is a 2.0 beta version I suggest you remove all .history files and try opening the session again.

Take backups of the files in the session directory before doing anything. There should be no need to back up the sound files though.

thanks for the fast reply. i am using ardour 0.99.3.

i could solve the problem - i remembered that ardour had crashed when i tried to zoom in too close - there’s a bug, ardour just crashes when you do this but saves the zoom level in an additional XML file (instant.xml, same folder as the session.ardour file). so each time your start that session, ardour reads the zoom information and crashes again.

you have to delete (better: move) instant.xml. ardour should create a new one when starting the project now; if it doesn’t, simply copy the instant.xml from another session project to the folder where your “damaged” session is located. ardour should start normally then, you only have to go through your settings and check if everything is still okay.