Synchronization problems

Hi, I have two problems recording with a midi keyboard in Ardour 6.9:

  1. I record with the metronome on, playing perfectly in time. But when I replay the MIDI track recorded, with the metronome on to record a second track, the recorded notes are played early ahead of the metronome!!
    Why?

  2. I record on two MIDI tracks, one at a time, playing perfectly synchronized. But when I replay the two recorded tracks, the two tracks are completely out of phase.
    for example using these plugins:

Track 1: Surge-Basses-Deep End
Track 2: Surge-Basses- Digibass.

I tried to change the buffer size, but it doesn’t change anything.

Where can the problem be?
Are the two problems related to each other?

Thank you
a.

My configuration:

Ubuntu 18.04
QjackCtl - JACK 0.4.5
Ardour 6.9.0 “After Bach” (rev 6.9) Intel 64-bit - debug
a MIDI keyboard connected to pc with a USB MIDI interface.

Hi

There might be some deeper answer from ardour devs but this might come from the midi interface itself…

As advised multiple times in the forum, you should be using Alsa driver from ardour (so disable jack before starting ardour).

As a workaround you can also change the latency of a given track. You can do it by right clicking on the head of your midi track. There is a menu (cant remember precisely the title…) dealing with latency which allows you to set a manual latency in samples or in ms…

Maybe for debugging and helping others better help you, you could take a screenshot of your track and post it here. With the appropriate zooming so that one can see if there is an offset between the time grid and the notes…

Hope it helps.

I have to correct myself, actually by setting (in “Windows, Audio/Midi Setup”) the buffer size to 256 samples, with a latency of 5.8 ms, the synchronization is perfect, both with the metronome and between tracks.
The problem was that I didn’t notice Ardour reset to 1024 samples, even though in QJackCtl it is fixed at 256. So in Ardour I often have to set it back to 256.

I use Jack with Alsa drivers, without Jack I have never been able to get Ardour to work on Ubuntu 18.04.

Instead the way to set the latency by clicking on the head of the MIDI track, I’m not able to find it.

Bye,

a.

If jackd is started before Ardour, Ardour has to use the latency settings from JACK (all JACK applications must use the identical buffer settings, there is no option). So if you have to change the setting in Ardour that means that you are not using JACK always when you think you are, or jackd is not running first, so Ardour starts jackd using whatever settings you configure in the Ardour backend.
To avoid that, just start jackd before Ardour using your QJackCtl settings.

Hello,
I don’t know why you think I start Jack after Ardour.
Jack I always start it first, then all other programs.
Bye,

a.

Because it is not possible for Ardour to run with period 1024 if jackd is already running with period 256.