Success with Thunderbolt 3 to Firewire Adapter

I have a Mackie Onyx 1640 - big old mixer with an optional Firewire mixer expansion card installed. Yay for learning how to replace power supply capacitors.

I have a Dell Precision 3530 with a Thunderbolt 3 port; it came with Ubuntu installed; I’ve added the KXStudio repository and packages, and they along with the system’s firmware are all up-to-date.

I’ve gotten good results using a StarTech Thunderbolt 3 to Thunderbolt 2 adapter, an Apple Thunderbolt to Firewire (9-pin) adapter, and a 9-pin Firewire to 6-pin Firewire Cable/adapter.

I’ve had 58 overruns in the course of seven days, which is nowhere near as good as the performance of my very old and slow desktop with a TI chipset-based Firewire PCIe card in it, but is completely fine for my needs, and better than the 2-channel usb interface (focusrite 2i2) that I used with the machine for a month or two (which was also okay but a little rough for playing software synthesizers at ~10ms latency.)

I’m running at 44.1kHz, 256 samples, for a latency of 5.8ms.

I tried this same setup with a Focusrite Saffire Pro 40 and could swear the routing of input channels was jumping around. I’d like to test it more, both to establish a more portable setup for myself and to provide the community with some knowledge, but can’t really promise a timeline on that. Would love to hear if others have tried.

I just want to report I’m very successfully running a Firewire interface that doesn’t require routing control software through a series of adapters into a Thunderbolt 3 port. I had trouble finding such anecdotes online when I bought this laptop a few months ago.

1 Like

I have had some issues with the Saffire Pro 40 and locally saved mixing config cache getting ‘corrupted’ where it had to be reloaded. This was using other OSes so it may be that you are running into a possibly hardware failing issue, but obviously hard to tell.


Thanks for the heads up - I’ll reconnect it to the old machine and see if it still functions properly. Outside of power outages it had probably been on for a few years solid before I tried it with the new computer - I’ve definitely had hardware failures present themselves before after turning equipment off that usually doesn’t get turned off.

I am trying to set up my RME Fireface 400 in Ubuntu 20.10. I may have a question regarding this particular set up:

Apple Thunderbolt 3 to 2 + Apple Thunderbolt 2 to Firewire 9 pin (800), + cable Firewire 800/400.

First dongle is apparently recognized:

lsusb gave me

Bus 002 Device 002: ID 0781:5583 SanDisk Corp. Ultra Fit
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 04f2:b65a Chicony Electronics Co., Ltd HD Webcam
Bus 001 Device 004: ID 8087:0aaa Intel Corp. Bluetooth 9460/9560 Jefferson Peak (JfP)
Bus 001 Device 002: ID 05ac:1657 Apple, Inc. Thunderbolt 3 (USB-C) to Thunderbolt 2 Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

But I have some problem with the second adapter (thunderbolt 2 to Firewire). I read somewhere I should set the raw1394 into the /ect/modules, but actually I dont have idea how to solve this step.

many thnx