Struggling to get a working configuration for latency compensation

Hi folks,

I’d appreciate some help here, maybe just a sanity check on what I’m doing as it’s not making any sense to me.

I’m using Ardour 6.5.0 and a Behringer UMC404HD. I’m mostly recording live instruments via mics but am really struggling to get a latency setting that works and all of my tracks seem to be falling consistently off beat no matter what I do.

I’ve been trying an experiment, repeating the following steps on 2 different tracks for various different latency settings:

  • Record the click track played through headphones into a mic.
  • Mute the click, play back the recording of the click track and record it onto another track.

I ran ‘Calibrate audio’ with a cable and got 320 in, 320 out. I used this to record 2 tracks as above, then changed the input and output values via ‘Window → Audio Setup → Stop → Change values → Start’. I muted all the existing channels each time I changed to new settings.

I repeated the process with ‘640 in, 0 out’ and ‘0 in, 640 out’.

I’m assuming (maybe I’m wrong?) that when I have a good configuration that the recording of the click, and the recording of that recording will both fall pretty much on the bar lines. But what I see is that all 3 configurations above are offset from the bar lines by similar amounts. It’s quite a sizeable difference, and very clearly audible :thinking:

Any advice on what I could try to get a useable setup would be greatly appreciated.

Sample rate is 48khz, here’s the latency calibration measurements

When bouncing a track to another make sure that there are no other input connections.

[no input] → Track A → Track B → …

If Track B also is connected to some physical input, it will be aligned to that. You could also override alignment in the context menu of the track header. It should be automatically set to “Capture Time”.

As for why re-recording the click does not align after calibrating latency is a mystery. I have just tested this (using Ardour 7.3.78). Are you using a loopback cable to calibrate? or Headphone → Mic

Thanks Robin,

I’m not ‘bouncing’ any of the tracks purely in software, if that’s what you mean?

  1. I have track A connected to my mic via input 1
  2. I record the click on track A playing out of the headphones and into the mic
  3. I turn off the metronome, disarm track A and arm track B for record
  4. I connect track B to the mic via input 1
  5. I playback track A through the headphones, into the mic and record it onto track B

Do you mean I should disconnect the input to track A before recording on track B?

I’ve haven’t touched ‘Alignment’ in the context menu on any of the tracks, they all say Automatic (based on I/O connections) - Currently: Existing material

I calibrated via a loopback cable.

Ah OK. your step by step explanation makes it clear. This should work reliably.

The only other idea I have why this can fail is that use you use USB soundcard. I see that your session has dropouts (x-run)

With USB soundcard the systemic-latency can change every time the soundcard is started or when there is an x-run. This is due to additional kernel side buffering and was mitigates in recent Linux 6.0 kernel. Can you check if repeatedly measuring the systemic-latency always produces the same results. See also: Hardware latency not constant? - #2 by x42

I also just remembered that 6.5 has a bug that newly created tracks are not correctly compensate when using JACK (0008472: Newly added audio tracks are not correctly compensated for latency until Ardour session is reloaded - MantisBT). So you first have to create all tracks and then re-load the session, or update to Ardour 6.6 or better yet Ardour 7.

Thanks again Robin.

I think I get the same results every time I run the calibration, I haven’t been paying that much attention though, I could be wrong. I’d discounted the x-run related problems because my reading lead me to believe this could introduce very small changes whereas I was seeing errors of up to around 1000 samples. However the thread you linked indicates there can be large differences so maybe it is part of my issues.

The issue you describe with 6.5 feels very likely to be part of my problems, and I definitely think I’ve been having issues where the latency changes don’t seem to take effect without a restart.

I’ve just installed 7.3.0, run a calibration - interestingly this returned a slightly different value to 6.5 - 668 vs 640 total.

Repeating the ‘record the click, record the recording of the click’ process again using the default values from the calibration on 7.3.0 gives me an almost perfect result.

So thanks heaps for your help Robin, really appreciate it. I’ll come back if the problems persist but first glance it looks like upgrading may have solved it. :crossed_fingers: :slightly_smiling_face:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.