Still got the mute problem with 2.8.9 // Font size problem


i’m new to linux, ubuntu, and ardour… So, i compiled ardour 2.8.9, to avoid the mute problem.

But it still doesn’t work… i have to right-click, select what i want… ok for a one-track session, but it becomes a problem while getting more tracks…

Please help !!! i’d just like to click the “M” button, to have the track muted…

Second problem: i choose an 8 font size in the “appearance” menu of ubuntu 10.04. everything goes ok (firefox, desktop…), except ardour, which stays really big big big… and doesn’t fit my screen…

How can i solve this problem ?..

Thanks a lot

for the second problem:

menu->window->preferences->misc tab->font scalling.

for the first problem - use the svn version, the mute problem got resolved just after the 2.8.9 release. or edit your ardour.rc file.


thanks for answering me :slight_smile:

i’ve got the french version of ubuntu… i don’t know what “misc tab” is… is it the window where you can choose themes ? (“Apparence” in french) … because i’ve already been there, to put the font size at 8… and it doesn’t work at all, with ardour…

What is the svn version ?

both “ardour.rc” and “ardour_system.rc”, give a “yes” to the 4 lines in relation with mute.

So… i really don’t understand…

go to the main menu called window and than choose the last entry ‘preferences’ …or just pres alt+o…
they are several tabs in this dialog, choose the forelast one and move the slider called font scalling in the top of this tab. is not that heavy.


Ok… there seems to have some differences between your version and mine, because we were talking about the same thing, in fact. I do not have this option in “window”, but in “appearence”… And, my problem stay unsolved for the moment…

thanks for trying, doc !

…for the mute problem:

edit the file /usr/etc/ardour2/ardour_system.rc

to look like this:

< Option name=“mute-affects-pre-fader” value=“yes”/>
< Option name=“mute-affects-post-fader” value=“yes”/>
< Option name=“mute-affects-control-outs” value=“yes”/>
< Option name=“mute-affects-main-outs” value=“yes”/>

perhaps you have a “1” , “no” or “0” as a value, but it should be “yes”.
do not change anything else, only the value.


< Option name=“mute-affects-pre-fader” value=“yes”/>
< Option name=“mute-affects-post-fader” value=“yes”/>
< Option name=“mute-affects-control-outs” value=“yes”/>
< Option name=“mute-affects-main-outs” value=“yes”/>

That’s what i have with both ardour.rc and ardour_system.rc !.. i tried to replace “yes” by “y”, by “1”… no result…

it should say “yes” but i think it only affects a new session…
not sure though.


The font size setting for Ardour is within the preferences window for Ardour. I think you are setting the font sizes generally for your OS and expecting Ardour to follow, this won’t happen.

In Ardour open the ‘window’ menu and select ‘preferences’ at the bottom. Now in the 6th tab along there is a slider called font scaling, this will change the font size within Ardour.

Oh chrisg… thank you…

i think i need some fresh air !!! i’ve been spending to much time desperatly trying to learn about ubuntu, ardour… trying to fix problems…

i may have done what you told me to do, the first time… but… a few bugs later… just forgot that !!!

however… why does it work with firefox (for example) ?.. i mean, changing generally for the OS, does change the font size in firefox… and other applications, i guess…

well, now, everything is ok with ardour… in terms of font size !!! :wink:

Still don’t have any solution to the mute pb…

Ardour uses its own theme and font settings. You will notice that if you change Ubuntus theme Ardour also will not change to follow that. It’s a decision that has been made to keep Ardour looking and feeling like Ardour. If the colours changed with the theme then certain elements of Ardour just wouldn’t look right or work properly for the user. The font scaling is implemented along the same lines.

As for the mute bug, it really should be fixed in 2.8.9, so I don’t understand what is happening there.

Are you sure you are really running 2.8.9 (look inthe help menu) ? If you built it yourself what install path did you specify ? If you didn’t specify one then it has probably installed into /usr/local/bin , rather that /usr/bin , therefore no overwriting the original installed version.

Try building and re-installing again, this time with the PREFIX=/usr (or what ever the exact syntax is) switch to scons


just to test, run /usr/local/bin/ardour2

If this is what has happened, then you are mistakenly still running the original packaged version installed with Ubuntu.

Yes, first i did scons PREFIX=/usr
At the end of the process, i did a sudo checkinstall -D scons install

Ardour runs. But Mute is not ok “by default”. I still have to right click and select.
It’s the 2.8.9 version, compiled from revision (?) 7212

that’s all i can say… i’m lost…

By the way, now i’m not running ubuntu, but Xubuntu, and i followed some indication on a specialized website to configure it.

But still got the same result with ardour…



I made a reinstall (just one more :wink: )… i found, this time i guess, the good file ardour.rc… “NO” everywhere… i put “YES”, and now, it works…

damn, i’m so tired ! :slight_smile:

thanks for your help !