Starting ardour with a session as argument is crashing with GLib-ERROR

Hi all,
already filed a bug report but maybe it makes sense to check with other windows users first :wink:

I wanted to start Ardour directly into a session from command line, e.g.
“C:\Program Files\Ardour8\bin\ardour.exe” mySession
(the help says Usage: Ardour [ OPTIONS ] [ SESSION-NAME ] but I also tried with the full path to the ardour-file of the session with the same result.)

It starts up (showing the splashscreen) until in the commandline I can see:
Ardour: [INFO]: Loading bindings from C:\Program Files\Ardour8\share\ardour8\ardour.keys
Loading ui configuration file C:\Program Files\Ardour8\share\ardour8\clearlooks.rc

(ardour.exe:7176): GLib-ERROR **: 14:48:55.982: creating thread ‘gmain’: Error setting new thread priority: Falscher Parameter.

I also tried creating a windows shortcut to ardour with the argument which also results in ardour not starting up (I expect the same error, as it is not visible I cant verify)

When I give a non-existing session name, it shows the audio/midi setup and crashes after I press the start button.

When I give a session that used another audio setup before, I also receive the audio/midi setup and it crashes after I press the start button.
So it loads the session to some extend and then crashes.

Can someone running Ardour on windows please check? I just downloaded Ardour a few days ago, running 8.2.0.
Bug report is here:

Thanks and best regards

First, I don’t really know from Windows these days (the past quarter century, really). Given that, can you try:

  • Running the command-line with an existing session, but adding the “safe mode” argument (-d) before the session name. See this thread for a description of debugging errant plugins using binary search.
  • Opening Ardour from the command line without an existing session, e.g., “C:\Program Files\Ardour8\bin\ardour.exe” -N.

If neither of those gets you to a working Ardour session, then you may need to try moving aside any config files specific to your Ardour version. Here, I cannot guess at filenames, nor at the command-prompt / Windows shell syntax to use.

Hi and thanks for your reply.
the safe mode (-d) is not helping. Also using -N and a new session name as required argument is not successful. I used the following command:

“C:\Program Files\Ardour8\bin\ardour.exe” -N cmdtest

The only way to start it from command line is running it without any session name argument and then using the “Session Setup” dialog to either open an existing session or create a new session. This way everything is working fine.

I also tried on 2 other windows PCs with fresh installations and had the same issue on those machines.

Check that there aren’t any space characters in the path to your session file.

Also, did you remember to add .ardour to the end of ffile? e.g.

“C:\Program Files\Ardour8\bin\ardour.exe” D:\path\to\cmdtest\cmdtest.ardour

I tried something similar here and the session opened fine.

Thanks for your test. I tried different styles
The man pages only state session-name so I tried:
“C:\Program Files\Ardour8\bin\ardour.exe” Test
I also tried full path and filename:
“C:\Program Files\Ardour8\bin\ardour.exe” E:\Ardour\Test\Test.ardour
Result is the same. Which version of Ardour are you running? I just started with Ardour and downloaded the demo version with installer “Ardour-8.2.0-w64-Setup.exe”
Could it be an issue with the demo version? I wanted to test whether everything works before I buy and with this limitation I cant use it in my scenario.

I’m using the latest version although I build Ardour myself from the source code. I could maybe try the version that you downloaded but that’d need to wait until the weekend. You mentioned seeing some text just before the crash:-

	Ardour: [INFO]: Loading bindings from C:\Program Files\Ardour8\share\ardour8\ardour.keys
	Loading ui configuration file C:\Program Files\Ardour8\share\ardour8\clearlooks.rc

What seems to happen next is that Ardour runs a check to find out if there’s a more recent version available (for which it’d need the internet). So maybe you’ve some antivirus software that’s interfering with things at that stage? I don’t know why it’d only happen when you load an session via the Command Line though… that doesn’t really make sense.

Why do you need to load sessions via the Command Line anyway?

That would be great.
I dont know whether the update check is the problem as the next message that appears in the console if I dont use a session as an argument is:

Found nothing along C:\Users\mail\AppData\Local\Ardour8\templates;C:\Program Files\Ardour8\share\ardour8\templates;C:\Program Files\Ardour8\share\templates;C:\Program Files\Ardour8\build\templates;C:\Program Files\Ardour8\gtk2_ardour\templates;C:\Program Files\Ardour8/build\gtk2_ardour\templates
Set cursor set to default

When I start it with a non existing session-name, e.g.
“C:\Program Files\Ardour8\bin\ardour.exe” nonexistingsession
it shows the Audio/MIDI Setup window, then goes into the splashscreen and after the message “Indexing plugins” in the bottom left of the splashscreen it runs into the error.
That is the same when I use an existing session (only without the Audio/MIDI setup).

So it is already loading plugins etc.
I also tried with arguments -a -B -d -O -P -n but also same error.

The reason I want to load a session from command line is that I want to automate our band rehearsals. We generate a random setlist and if one of the band members is not present, we want him to be replaced by the recording. So I want to startup the ardour session of the song, using osc commands I mute all other tracks but the ones for the missing person and play the song.
I know I could also use ardour8-lua but with that I was also struggling in getting it to work at all in windows.
I setup a VM with Ubuntu and all of it works like a charm. Also in windows one I loaded the session everything is working. Last missing piece, I never thought of would make problems, is the session startup. Last exit is replacing windows in the band room with ubuntu but that causes other issues…

When I start it with a non existing session-name, e.g.
“C:\Program Files\Ardour8\bin\ardour.exe” nonexistingsession it shows the Audio/MIDI Setup window,

And what happens if you change some of the Audio.Midi settings? e.g. try changing the Audio System and Driver - and try setting MIDI System to None

Wow. Thats it… at least sort of.
The MIDI system seems to cause the error. When I change it to “None” it works. Even with existing sessions. It was set to “WinMME”, the only other available option.
Unfortunately this way I of course have no working MIDI setup (which I want to use to sync the sample pad of our drummer). I guess according to The Ardour Manual - Configuring MIDI I have to have a look at JACK, right?

Unfortunately my computer doesn’t have any MIDI hardware so I can’t tell if Jack would be helpful or not. Glad to know we eventually found the problem though!

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.