Stange playhead reset

Hey there,
I just ran into a strange playhead behaviour with OSX 10.11.1 and Ardour 4.4 - it resets to random positions. I made a short video/gif to show it.
Is this a bug? It happens after I zoomed via “Z” to the clip. Or did I just miss any preference setting?

Can you replicate this with the current nightly version?

No, sorry. I am no subscriber.


You don’t need to be a subscriber to test on the nightly (, you can still download the free/demo version, and run it side by side with your paid version. For this purpose it should allow you to test this issue fine.


I had this bug happen to me too (Ubuntu 14.04 64-bit). Both with Ardour 4.4 and Mixbus 3.
I did create a bug report:

A workaround that worked for me is to remove the ui_config file inside /home/user/.config/ardour4
Ardour creates a new ui_config file when started, and the bug dissapeared for me at least.
Though I have no idea where the ui_config file is on osx.

it’d be nice to diff the config - that may shed some light on which value lead to the behaviour.

on OSX it’s in $HOME/Library/Preferences/ardour4/ on windows in %localappdata%\ardour4\

PS. n/m the first part, I just saw the ticket already has a diff. thanks!

Just tried it with the latest nightly. Same issue.
I deleted the ui_config file and restarted Ardour. Same issue after (!) first zoom in. But its not reproducable but maybe its something that helps you.

I completely uninstalled everything (AppClean on OSX) and reinstalled the nightly demo - issue seems to be gone.