Sparta VST's not being recognized by Ardour or Carla

I am working on Linux Mint || Ardour 5.12.0 (rev 5.12) Intel 64-bit with a 4.4.0-53 kernel

I'm checking out these plugins: 
http://research.spa.aalto.fi/projects/sparta_vsts/ 
I followed the INSTALL instructions, installed libs they specified, copied the .so to /usr/lib/vst dir - started Ardour and plugin scan "sees" the plugins but I don't see them in the plugin manager
these are not Windows VST's but are supposed to work native in Ubuntu
has anyone else tried to get these working? if so, any luck?

also, many thanks to Paul, Robin and the whole Ardour team…coming back to Ardour after 5 years I was blown away by the progress you’ve made! I’m working on a new album and the tool is powerful beyond imagination - good work guys!! :slight_smile:

Nice! It’s great to see more plugins supporting GNU/Linux.

As for the issue at hand: Those are JUCE plugins compiled with JUCE’s default options gtk3 for webkit support.

Ardour is gtk2 based, and since gtk2/3 conflict the plugins cannot be load. This is a similar issue as ToneLib GFX VST not listed as plugin [solved]

Assuming that the plugins don’t need a web-browser in their GUI, please ask upstream to compile the binaries with <JUCEOPTIONS JUCE_WEB_BROWSER="0" /> (or compile them yourself with that option). That should make them work with Ardour.

You’re very welcome. Glad you like it!

the plugins that are packaged should be separate from manually installed ones, I would suggest placing such plugins in /usr/local/lib/vst without worrying that these plugins may be potentially deleted from a package… if it’s just for one user, I would just add them to ~/.vst but then it has to be added to the vst search path in the setup…