Space doesn't toggle Start / Stop anymore [SOLVED Linux]

I’ve come across a problem where the Space Bar doesn’t toggle Start / Stop anymore.
Working on some tempo maps it might be a mistriggered shortcut.

Now, when I press space, the editor switches to range mode and selects the loop range.
Any suggestions how to re-enable the standard mnemonic?

Please note: running Mixbus 5.2.191

Image: pressing space doesn’t trigger Start / Stop but switches to range mode.

Does pressing the “play” button with the mouse work?

If so, perhaps reset the keyboard shortcuts in Menu > Window > Keyboard Shortcuts

there’s an oddity with shortcuts with Ardour and Mixbus, if the user changes the keyboard shortcuts, the menus will not be updated to reflect the change after some time has passed – if the user wants to see the menus updated immediately, they would have to restart the application. The shortcuts though are actually updated, but the menus aren’t, and this may confuse a user if they did a lot of keyboard changes and may be relying on information given to them from the menu…

Ok, it is working again … through linux self-healing magic :desert_island::sunglasses:

Here’s what happened. Using the mouse to press play worked. I had tried the following without success:

  • reset keyboard shortcuts -> no success
  • bypass / close plugin windows -> no success
  • system reboot -> no success

Now, a day later, the space bar triggers “toggle roll” as if nothing happened - without any changes on my side. So, everything is ok, again.

Might be a glitch, might be a bug. I recall having edited some shortcuts so it might be in line with what @ahms described. Should I be able to reproduce the behavior that triggered it, I’ll post it.

Thanks for your suggestions.

Did you re-start ardour after resetting those?
In some cases new bindings didn’t become effective immediatly.

Yes, re-booted my box and then re-started the DAW.

Please note, this issue came up with mixbus 5.2.191.
Sorry for posting it on, but I work with both DAWs depending on the project.

To find the relevant playback operator key, a user can just use 'play '(with space) and ‘stop’ then verify both the Global and Editor tab,

there’ll be 5 relevant entries on the Editor tab, and 7 on the Global.

It’s not easy at first what the shortcuts do, so if a user clicks on that Print Bindings button they get more description for the shortkey items…

A same key can be unintentionally set in the Global’s Common, Transport and Editor tab areas, so it is a good idea to exercise imho removing shortcuts that the user is not familiar with.

Here I resorted to avoiding any confusion by doing just that, I just remove shortcuts I am not using, and as I become more familiar with a particular task I just add it to a shortkey.

I try to set the playback control to using something with the spacekey with the metakeys, but I make sure I am not cloning the same shortkey across the three keyboard setting areas that may provide similar things.

Imho if the user is not binding the items ‘Play selected *’ from the Editor tab, they should be setting the ‘Play selection’ found in the Global/Transport area.

From my mixbus keyboard settings, the user can see when typing 'play ’ (with space), they get the similarly named function item – though its possible the ‘Global’/Transport setting may be applying to more broad things I would not know about.

2019-10-26_22-48_1 2019-10-26_22-48

The problem was likely that the ‘Space’ shortkey was set in the Editor tab, and there was this same shortkey also set in the Global/Transport area.

The search field in the keyboard settings also searches keybindings, so if you type ‘space’ in the search box, it will filter things directly to the items that have the ‘Space’ or things like ‘Alt-Space’ binded to them.

So even if you’re not familiar with the item names, you can use the name of the shortcut to hunt down potential overrides between the Editor and Global tab settings.

fwiw you can also sort the keybindings as well, by applying the ‘Shortcut’ column header and immediately see where the shortcut you’re after is binded.

To me this is the way I am going about it… I gave up trying to using any of the default keybindings and just removed all of them, then slowly just applying a couple of keybindings at a time…

A last note in case you missed the point I was trying to pass:
–> If the user sets the same shortkey on a non-Global tab as is also found in the Global tab, the non-Global tab keybinding takes over – in retrospect that the user is working within the contraints of the defined item.

Perhaps there can be a wizard tool added to the Ardour/Mixbus help menu to sort out this issue… that wouldn’t be such a bad idea imho.