Soundcract SI Console - Clicking Noises During Play Back

Hello, I have a very odd problem I am hoping someone might be able to help me figure out. It is a almost imperceptible clicking sound that comes through our house sound. If I had to describe what it sounds like, it’s almost like the clicking one hears on an a record player that has some scratches. It isn’t loud enough and constant enough to cause most people to notice but it is definitely perceptible. Hoping someone might have some ideas on what to check.

We use an Soundcraft SI 2 Expression Console with the USB-MADI intefrace Card going into our PC for mixng both Live and for Streaming. I’m running Arch Linux with the latest kernel (I think 5.6) but not the real time kernel (Networking interface doesn’t come up with RT kernel, another problem to trouble shoot. The same clicking issue persists with the real time kernel so I think that can be eliminated as a culprit though). I’m using the latest stable version of Ardour 5 from the Arch repos.

The PC we have is a Ryzen 1600, 6 core, 12 thread PC loaded with 16gb of RAM. All default settings (no overcocking). I’m running Jack Audio with 48khz sampling, a buffer size of 256 and period of 2. I’ve tried with and without Dithering and with and without Soft Mode, neither seem to make any signifcant difference that I can tell. My DSP load hovers between 3% and typically ~15%+ with only 2 xruns occuring just when Ardour fist starts. The delay is 5.3ms with this combination. I use OBS for processing video from 2 1080 video sources and Ardour for mixing everything together. In Ardour we have about 20 channels coming from a mixture of live sources (mics, guitars, etc…) and MIDI sources (Drum Kit, Keyboard) generating sound through SondFonts. I use mostly Calf plugins for my Gates, Compressors, Stereo, EQ, I also have the Dragonfly Reverb Plugin on some channels. With all of this going on, my CPU usage is typically in the 20% to 30% range. All of the inputs feed into the console then gets sent via USB into the PC, through Jack, into Ardour where it is mixed and then pushed out back out through either OBS and our Live Stream or back into the console through the USB interface then back out to the house.

Back to the clicking sound. It is typically a very quite clicking, usually in bursts of 3 right in succession. It won’t do this while there is no sound coming in. It does happen however if a singer or instrument starts singing and increases substantially in volume but that isn’t always the case. Sometimes it can go several seconds without making the clicking sound, other times it will be more often.

The odd thing is I’m not getting any xruns, my DSP load is not high AND my live stream does not appear to have this same clicking sound (not absolutely confirmed but fairly confident). I’ve tried creating an entirely clean Ardour session with just two channels and no plugins and the issue persists. Increasing the Jack Audio buffer to 512 doesn’t seem to solve the problem either from the testing I have done plus again, no Xruns are occuring when this happens. I could go higher in the buffer but then there is too much delay for musicians so it’s not a viable solution.

The only thing that I can seem to correlate that will cause this if changes in volume from the input. IE, if someone on the mic is silent, it won’t happen at all but if they start singing loudly it will happen. I don’t think this is a clipping issue as the range is not triggering the clip indicator on the fader strip and the levels are well below the clipping level to begin with. Disabling plugins doesn’t make a difference and starting a fresh session with only two channels and no plugins did not stop it either.

Because this doesn’t seem to come through the Live Stream, I am beginning to question if it has something to do with the USB interface card and the Expression SI console. I see that the Windows driver does have some buffer settings that can be changed but I have no idea if it is possible to change those settings in Linux. I’m not certain how to do additional testing at this point so I am putting it up here for help.

Thanks in advance!

Sounds very much like a typical sync error where two devices are not properly synced to the same master sync. Samples get lost and depending on where the sample gets lost you hear a click or not. If the sample gets lost when there is sound it creates a jump in the waveform and you hear this as a click. If there is silence when a sample gets lost you can’t hear it because the waveform jumps from zero to zero.

Thank you for the reply. What would I do to test or resolve this? I will have to double check because if I’m not hearing this on the live stream portion but do hear it in the house then could it be a sync issue between the PC and the USB-MADI interface on the console?

Sorry I have no solution for you since I don’t use Madi or have that hardware. But yes I would suspect the problem might have something to do with your Madi devices syncing to incoming madi. Maybe its running on internal sync and you need to tell it to sync to incoming Madi ? Does it have the possibility to sync to external word clock ? It is always best to sync all devices streaming audio to each other to the same master sync and that is usually word clock.

The addin card is a USB / MADI interface card but we are not using the MADI portion, just the USB portion. I don’t be believe I have any access to driver configuration settings for the console that I am aware of.