Sound problem with Ardour 5

Hi,

I just changed my PC.
On the old PC I had an Ardor 4 license.
So I would like to test version 5 on the new one, so I installed the demo version.

I have a sound problem that I cannot resolve.
I contacted different forums but no one could give me a solution.

I’m on Xubuntu 19.10.
The sound card (integrated into the MSI X470 Gaming Pro Carbon) appears in Alsamixer as “HD-Audio Generic” with an ATI R6xx HDMI chip.

In Alsamixer I have two choices of sound cards:
0 HD-Audio Generic
1 HD-Audio Generic

The first (0) gives me only S / PDIF (0 to 5) in adjustment
The second (1) gives me all the traditional settings.

In Jackd, he sees 3:
HD-Audio Generic (hw: 0)
HD-Audio Generic_1 (hw: 1)
HD-Audio Generic_1,0 ALC1220 Analog (hw: 1,0)
It seems that only Generic_1 allows me to connect Jackd

No particular errors when it comes to Jackd when I launch him alone apart from a scrolling of “16: 44: 16.108 Recovery from desynchronization (XRUN) (20 skipped).” that I think I already had on the old PC.

The problem is the same when using Alsa or Jackd.
I have a sound both slower than the wav file and more with cracks.
I just do “Import” then Play, to make sure it’s not a routing problem. If I import the wav next, it’s the same as reading.

This is an audio file to give you an idea. It is normally a jazz piano sound.
[https://www.carlbouchaux.com/wp-content/uploads/2019/12/recording-20191216-122651.mp3]

Ardor is well set to 44, like the wav file.
I tried with 32 or 16Bits and tested a little all the possible settings but nothing to do.

At installation I got the message:

“!!! WARNING !!! - Your system seems to use frequency scaling.
This can have a serious impact on audio latency.
For best results turn it off, e.g. by chosing the ‘performance’ governor.”

So I installed “indicator-cpufreq” and setup on Performances, but it’s the same.

You can see the “Configuration” of Ardour (About/Configuration) bellow.

All other software or sound systems work perfectly.
I can read a file without problem in a console with “aplay”.

Hi hope you’ll can help me.
Ask if you need something else.

Best regards,
Carl

Build documentation: False
Debuggable build: False
Export all symbols (backtrace): False
Install prefix: /usr
Strict compiler flags: []
Internal Shared Libraries: True
Use External Libraries: True
Library exports hidden: True
Free/Demo copy: False

ALSA DBus Reservation: False
Architecture flags: None
Aubio: True
AudioUnits: False
Build target: x86_64
Canvas Test UI: False
Beatbox test app: False
CoreAudio: False
CoreAudio 10.5 compat: False
Debug RT allocations: False
Debug Symbols: False
Denormal exceptions: False
FLAC: True
FPU optimization: True
Freedesktop files: True
Libjack linking: link
Libjack metadata: True
Lua Binding Doc: False
LV2 UI embedding: True
LV2 support: True
LV2 extensions: True
LXVST support: True
Mac VST support: False
OGG: True
Phone home: False
Process thread timing: False
Program name: Ardour
Samplerate: True
PT format: False
PTW32 Semaphore: False
Threaded WaveViews: True
Translation: True
Unit tests: False
Windows VST support: False
Wiimote support: True
Windows key: Mod4><Super

PortAudio Backend: False
CoreAudio/Midi Backend: False
ALSA Backend: True
Dummy backend: True
JACK Backend: True

Builstack: -system-
Mac i386 Architecture: False
Mac ppc Architecture: False

C compiler flags: [’-I<>’, ‘-Wdate-time’, ‘-D_FORTIFY_SOURCE=2’, ‘-g’, ‘-O2’, ‘-fdebug-prefix-map=<>=.’, ‘-fstack-protector-strong’, ‘-Wformat’, ‘-Werror=format-security’, ‘-DHAVE_RF64_RIFF’, ‘-DWAF_BUILD’, ‘-DNDEBUG’, ‘-fshow-column’, ‘-O3’, ‘-fomit-frame-pointer’, ‘-ffast-math’, ‘-fstrength-reduce’, ‘-pipe’, ‘-DARCH_X86’, ‘-mmmx’, ‘-msse’, ‘-mfpmath=sse’, ‘-DUSE_XMMINTRIN’, ‘-DBUILD_SSE_OPTIMIZATIONS’, ‘-DLXVST_64BIT’, ‘-Wall’, ‘-Wpointer-arith’, ‘-Wcast-qual’, ‘-Wcast-align’, ‘-Wno-unused-parameter’, ‘-DBOOST_SYSTEM_NO_DEPRECATED’, ‘-D_ISOC9X_SOURCE’, ‘-D_LARGEFILE64_SOURCE’, ‘-D_FILE_OFFSET_BITS=64’, ‘-DENABLE_NLS’, ‘-DPROGRAM_NAME=“Ardour”’, ‘-DPROGRAM_VERSION=“5”’, ‘-Wstrict-prototypes’, ‘-Wmissing-prototypes’]
C++ compiler flags: [’-I<>’, ‘-Wdate-time’, ‘-D_FORTIFY_SOURCE=2’, ‘-g’, ‘-O2’, ‘-fdebug-prefix-map=<>=.’, ‘-fstack-protector-strong’, ‘-Wformat’, ‘-Werror=format-security’, ‘-I/usr/include/qm-dsp’, ‘-DHAVE_RF64_RIFF’, ‘-DWAF_BUILD’, ‘-DNDEBUG’, ‘-fshow-column’, ‘-O3’, ‘-fomit-frame-pointer’, ‘-ffast-math’, ‘-fstrength-reduce’, ‘-pipe’, ‘-DARCH_X86’, ‘-mmmx’, ‘-msse’, ‘-mfpmath=sse’, ‘-DUSE_XMMINTRIN’, ‘-DBUILD_SSE_OPTIMIZATIONS’, ‘-DLXVST_64BIT’, ‘-Wall’, ‘-Wpointer-arith’, ‘-Wcast-qual’, ‘-Wcast-align’, ‘-Wno-unused-parameter’, ‘-DBOOST_SYSTEM_NO_DEPRECATED’, ‘-D_ISOC9X_SOURCE’, ‘-D_LARGEFILE64_SOURCE’, ‘-D_FILE_OFFSET_BITS=64’, ‘-DENABLE_NLS’, ‘-DPROGRAM_NAME=“Ardour”’, ‘-DPROGRAM_VERSION=“5”’, ‘-std=c++11’, ‘-DBOOST_NO_AUTO_PTR’, ‘-Woverloaded-virtual’, ‘-Wno-unused-local-typedefs’, ‘-D__STDC_LIMIT_MACROS’, ‘-D__STDC_FORMAT_MACROS’, ‘-DCANVAS_COMPATIBILITY’, ‘-DCANVAS_DEBUG’]
Linker flags: [’-Wl,-Bsymbolic-functions’, ‘-Wl,-z,relro’, ‘-Wl,-z,now’, ‘-Wl,–as-needed’, ‘-Wl,-Bsymbolic-functions’, ‘-Wl,-z,relro’, ‘-Wl,-z,now’, ‘-Wl,–as-needed’]

With Ardour 5, if you have multiple soundcards with the same name, here all are named “HD-Audio Generic” you’ll have to use JACK (with hardware hw: id) to distinguish between them.

This has been addressed recently for upcoming Ardour6.

I just did the test again with all the sound cards in jackd, one by one, that does not change the problem.
Anyway I only use Ardour so I prefer not to use jack at the moment.

I just did another test.
I booted on a Linux Av and there Ardor works perfectly with Alsa without touching anything to the system.
So this is I think a problem of adjustment or configuration but I really do not see what …

Consider switching to AV Linux?

When I first set up a DAW, I tried various systems and AV Linux was the first that ran without any trouble at all. From that point onward (2013) I just continued using AV Linux and have done so through several versions of AV Linux and changes of hardware. Getting a Linux system set up to run audio production software is tricky, and I’ve found AV Linux a perfectly usable system for all kinds of other software tasks, although it is installed on a machine that’s mainly used as a studio computer.

A possible concern with AV Linux is that development support is fairly slow as it’s a one man operation. The 2019 release is based on Debian Stretch. You can’t use the Debian upgrade process; instead you wait for the next AV Linux release and re-install when convenient. It’s not too hard to do, though, and the system is very well documented, and you can safely install extra Debian packages if you need them.

Thanks for the answer and the explanations but I don’t want to switch to AV Linux.
My computer is not primarily for audio and, especially for the graphics card, which only works with the latest version of the kernel, I use Xubuntu.
I have never had a problem for 5 years that I use Ardour on different versions even if sometimes I had to use Jack.
I would like to find a solution without having to wait for Ardour 6 .
So I hope someone can help me.

Is the playback issue only with imported files? Have you tried tracking anything? Are all of your soundcard’s inputs and outputs recognized in Ardour?

I did not test by recording something because I have nothing input on the PC and I do not know how to record the audio stream from the PC.

In the start panel, I have the two main cards in Entry and Exit:
HDA ATI HDMI
HD-Audio Generic
So I take HD-Audio Generic

What is certain is that with Av Linux everything works with the same version of Ardour and the same hardware configuration.
I will resuscitate Av Linux again to check how Ardour is configured with Alsa.

Have you tried running this “Linux configuration checker for systems to be used for real-time audio”?

https://github.com/raboof/realtimeconfigquickscan

I recently bought a new used Thinkpad T440s and wanted to take the opportunity to try to switch from Xubuntu to Manjaro, which I’ve heard many good things about. At first, I had some issues with cracks during playback, and also xruns. Then I ran the above checker and followed the excellent recommendations it offered. Now everything works perfectly smooth, both when it comes to playback and recording. Don’t know if it’s applicable to you, but couldn’t hurt to try.

Thanks for the idea.
I check and correct all the points to have “good” exept the RT Kernel (not possible at the moment) but unfotunately the result is the same ;-(

Try setting the samplerate at 48 kHz.

I’m making a lot of assumptions here and I could be totally wrong (as usual).
Only thing I can think of is that the soundcard or driver doesn’t like 44.1 kHz for some reason.
I’m assuming here the card runs on 48 kHz out of the box. Desktop audio (pulseaudio) would resample audiofiles to 48 kHz and all sounds OK. As soon as you force the samplerate to 44.1 things go haywire.

Set the rate to 48 khZ
Start new session.
Import wav file (ardour may ask to resample it)
see what happens

Don’t try using an old project (in 44.1 kHz)

Let us know how things went.
good luck :crossed_fingers:

Thank you for this track that I followed.
So I started Ardour in 48khz.
In import I heard a red message of course which warns that the file is in 41khz and the listening is always horrible.
The import is quite long because of the conversion to 48.
Unfortunately after reading, nothing has changed.
It was worth a try …

I remembered this morning that I had a Focusrite Scarlett in the corner.
So I tried with it and there everything works.
So it’s a compatibility problem between Ardour and my sound card.
Until I find a solution, I can work with the Focusrite, that’s it already!
So I just bought the license for version 5.
I stay tuned for any help that can help me use my sound card …

If your card works in AV Linux then it’s not a compatibility problem between Ardour and your sound card per se, but between your Xubuntu 19.10 setup and the card.

No idea what that exact problem might be, though.

Yes Peder, it’s between my Xubuntu and the card but only with Ardour because all the others audio softwares work good…

I just need to clarify something. Nobody buys a license for Ardour. It is released under the GPL and is freely distributable (copyable) and modifiable for whatever purpose suits you. What we ask you to pay us for (so that a couple of people can work full time on the project) is the ease of getting a prebuilt, ready-to-run version of the program. The license is the GPL whether you pay us or get Ardour from somewhere else or build it yourself.

Yes Paul, it’s right and perfect explain on Ardour and website.
Sorry for the mistake and always happy to contribute to this beautifull projject !