Sound not outputting


(astor) #1

Bought and downloaded Ardour and started playing with it, accidentally crashing it twice due to my audio output getting unplugged. The sound worked fine and everything, but on one boot it simply stopped outputting any sound. According to Arduor, it’s making noise and it’s meant to be outputting to a certain device. The device reads no output.

Ardour still takes from my input and I tried with several different outputs, but Ardour is simply not outputting sound, according to Windows.


(Saam R Sany) #2

Can you post screenshots of your Audio Setup window and Audio Connections window? Also, what interface are you using?


(astor) #3

Here are the screenshots.

I don’t know what an interface is, I admit to having no idea what I’m doing, but Ardour was working without one for a while. That or I have one that I don’t know about and don’t know how to check it.

I’m not sure what the Audio Connection manager is, but any combination of those little boxes being ticked seems to do nothing. In hardware/hardware, if I check any of those boxes I can hear my input loud and clear with a very noticeable delay. All other boxes in all other tabs don’t seem to do anything for me.


(Robin Gareus) #4

It seems that you’re using different devices for input and output. Input: usb-mic, output: realtek HDA (onboard soundcard) . That doesn’t usually work. Try using the realtek for both.

The connection manager screenshot does not show if master-bus output is connected to the soundcard. Look at the Mixer window (Menu > Window > MIxer, or “Mixer” button top-right).

Does the master-bus (right-side) level-meter move and show a signal? Check the connections there:


(astor) #5

The different devices was a mistake on my part for screenshotting it that way. Normally I have it both inputting and outputting on my RP500 board with the same issue, like this.

I think I know what you’re talking about, but your stuff looks different. I don’t seem to have a hardware tab under master input and I’m not sure what that 1/2 you have is Also unsure of what you mean by right-click shows matrix.

The left mixer thing labelled audio shows that my guitar is coming through from the board in input for certain. The right labelled master shows absolutely no movement no matter what.


(Saam R Sany) #6

Robin is trying to show you two ways of making sure that the master bus is connected to Playback Channel 1 & Channel 2. One way is through the Audio Connection Window, the other way is to see if it says “1&2” in the bottom of the Master Buss strip of the Mixer Window. If it isn’t, you can edit it in the Audio Connections window, which you can get to by right-clicking on that box at the bottom of the Master Buss Strip.
So just to be clear (because you mentioned Master Input), lets go through the connections, which isn’t easy to explain clearly, but I’ll try…

  1. First of all, the individual tracks should be routed to your Master Buss. That means in the Audio Connections menu, you select the “Ardour Tracks” tab on the vertical axis and the “Ardour Busses” tab on the horizontal axis. Each of these tracks should be connected to the Master Buss. You mentioned that it seems your guitar is only coming in on the left. It may be because the guitar is only feeding into one channel of the Master Buss (it could also be because the guitar is recording to only the Left channel of a stereo track).
  2. If all the tracks are fed to the Master Buss, then you want to select the “Ardour Busses” tab on the vertical axis and the “Hardware” tab on the horizontal axis. Now make sure the Master Buss channels are being fed into the “Playback 1” and “Playback 2” (like what Robin was illustrating above).
    Finally, I did notice in your imgur post that your Master Buss is set up in three channels. Is that intentional? If so, then you will need a “Playback 3”, but I doubt the RP500 has three channel audio playback.

(astor) #7

I think I accidentally added a third channel while clicking around like a confused ape. Anywho, I believe I see what you’re trying to get me to do.

Ardour Tracks into Master, Master into hardware. So I had this, which would take from Master and put into Tracks. That’s backwards, so I fixed it. The issue from after that is what’s causing no output.

Here is an album showing all of my connections. Audio comes in from hardware (my RP500), goes into the Ardour track, and from there, goes into the master buss. There is no hardware destination however, so it just sits there in the master buss.


(astor) #8

Interesting development: Having it output to my computer headphones rather than the board allows me to see a hardware option. I’d much rather it instead go through the board and into those headphones so I can hear myself play, then play it back to myself without switching headphones, but alas.


(Saam R Sany) #9

Right, by selecting the computer headphones as the output device the headphones will become the playback channels that you see in the “Hardware” tab. If you keep the board as the output device you should get the result you want.


(astor) #10

Thought of that, didn’t work. Edit: To elaborate, even though I have the output set to my board, it does not seem to want to output to that board. Switching the output to the board removes the hardware destination channel and gets no sound.


(Saam R Sany) #11

Oh I’m sorry I misunderstood. Are you sure the RP500 is setup to receive audio via USB? I don’t have any experience with that unit but I imagine its a POD type of product, and I know my old POD couldn’t receive audio, only send.


(Saam R Sany) #12

Also, if you’re concerned with hearing yourself play, you should be able to route the track you are recording guitar to to also go through the master buss and into your computer headphones. Not exactly the solution you are looking for, but you’ll be able to hear yourself play in realtime as well as whatever other tracks in the project.


(astor) #13

Yeah, I figure that would be the last option is to route it that way, but the way I was doing it before had my headphones connected directly to the board for no delay as well as having the tracks output to the board headphones. I know the board is capable of doing that because I’m able to have windows output to the board and it would go through the headphones that way. I suppose routing board > comp headphones will do, I just hope there’s no noticeable delay. Edit: There is very noticeable delay.


(johann_cat) #14

I had a similar problem and can confirm that Robin’s advice above is correct.
I am using Ardour 5.12 on Windows with a Scarlett 18i20 as a mic/ input board and a Faderport8 as a surface control.

I made a trial recording and everything looked good on Ardour, and I had live monitor sound, but no playback sound. The solution, as Robin says, is to go to Mixer and make sure Output 1/ Output 2 are selected in the Master fader (the default was something else.) See screenshot.

I would also add that my initial impression is that the interface of Ardour 5.12 and the Faderport8 seems very accurate–many thanks to those who did that.