Sound is being input into Ardour, but I can't hear anything?


(Katiepardee1) #1

Hello! I have installed Ardour on my Ubuntu. I am using the Behringer 1204USB Mixer as an input. After setting the sound card for the USB port, via the alsamixer code in the terminal, the sound is =being input into Ardour, as I can see it being recorded (yay). However, I can’t hear anything. I can’t even hear it when it plays back the recording. I told the monitoring to be handled by Ardour and not my mixer, I’ve checked everywhere to make sure I don’t have anything muted… The sound elsewhere on my computer is working fine. Maybe it’s a problem with the way I configured JACK? Any help would be greatly appreciated! Thanks!


(Len) #2

First question has to be, are you also using the 1204 as your output? or are you expecting the audio to come out of your computer? Having the audio come out of your computer while recording with 1204USB will not work (unless you have the 18.10 version of ubuntustudio-controls). You should hear the output if you plug headphones into the 1204 and select the “2-tr/USB” source next to the headphones level. Or if you have speakers connected to the mixer main outs there is a “2-tr/usb to main” button.


(Mikael Hartzell) #3

I don’t own the device, but just tried it on Linux a couple of hours ago :slight_smile: I used jack and recording and playback worked both ok.

If you are using headphones connected to the UFX1204 you need to route audio coming in from Ardour through USB to the UFX1204’s main mix bus for you to hear it. Use the buttons shown in the picture below to do this:

If you use jack you need to tell it that you want to use UFX1204 as your audio device otherwise it will probably default to using your motherboard audio. If you change your audio device our your Linux desktop it won’t affect what card jack is using.

If you start jack using QjackCTRL you need to select your audio device from its “Interface” drop down box. Here is a picture of QjackCTRL when I have selected Presonus Audiobox 18181VSL as my audio device.

I would suggest you to let UFX1204 to handle monitoring since it can do it. The benefits are: there is no latency between what you input to the mixer and what you hear from the headphones. You also can use bigger buffer size (1024) in jack which results in very stable recording and playback. You are unlikely ever to get any xruns with a buffer this big.


(Mikael Hartzell) #4

@Katiepardee1 Sorry it seems that Behringer has more than one device called ‘1204’ and yours is probably not the UFX1204. However the 1204USB also seems to have a physical button that allows you to route sound coming from the USB to the mixers main bus (2 - TR / USB to main). The QJackCTRL part of my post is relevant for any device using Jack.


(Katiepardee1) #5

Oh perfect thank you so much! That helped so much. I got it to work now. I am so grateful!

-Katie


(Katiepardee1) #6

Thanks Len! I feel kinda dumb that I didn’t figure out what those buttons did. Thanks for your help!

-Katie