Sound Devices MixPre-3 on linux

I’ve finally managed to get my Mixpre 3 to work on linux.
It’s undelicate… but it seems to work at all sample rates, 2 in 2 out.

  1. Launch Ardour session (until sound settings) or qjackctl, MixPre connected.
    (you have to configure those, even if they fail, to be ready for the last step)
  2. Switch off the MixPre
  3. Switch on the MixPre, and as soon as it’s on and ready,
  4. start the sound/session on ardour or start jack.

Tested on:
AVlinux MXedition (great distro by the way).
Connected by thunderbolt3, usb-c or usb-A.
Kernels:
5.10.0-13.2-liquorix-amd64
5.9.1-rt20avl1 (but I had other troubles with this kernel, try for yourself)
5.9.1-avl1-lowlatency
MixPre firmware: 7.10

Still need to switch off/on everytime I stop jack, ardour/, or change samplerate.

I have a MixPre-6 II working in Linux but I don’t seem to need to switch the device off and on to get it working. Strange that you need to do that but glad you have it up and running! I don’t have a USB-C port on my desktop and therefore need to use a USB-A cable plus either the PSU or a power bank. I’m not sure that would make a difference though.

1 Like

A somewhat tangential reply, but it would be great if Ardour could recognize markers inserted by the MixPre when it’s used as a standalone recorder. Some other DAWs do (Reaper for example, and Acon Digital’s Acoustica audio editor does too); apparently there’s some metadata in the WAV file that the DAW can capture to recreate those markers. I searched the manual to see if there’s a way to do this (they are not imported automatically) and couldn’t find anything, am I missing it?

Keep in mind that Markers in Ardour are global on the timeline, while the marker in your case would correspond to a source file (or region). So in order for them to be useful, Ardour will first have to support per-region markers. That is somewhere on the mid-term ToDo list.

1 Like

Strange, I never could make it work. I was about to get rid of it!
It’s a firts gen MixPre 3, maybe that. What’s the firmware version on yours?
I still can’t access all the inputs, as on win/ASIO. USB 3 or C…

Firmwire 7.10 also. I’ll dig it out and give it a run. I’ve since moved from MX Linux to Manjaro so I should probably check everything is in order!

EDIT: Well, that’s frustrating. No USB-A cable in sight. I put almost all my tech in storage in preparation for moving so only have the bare essentials in the apartment.

EDIT 2: Ordered a cable off Amazon…will be back in touch tomorrow or Tuesday :wink:

Thanks Robin – yes that’s how it works in Reaper: they are imported as region markers and there’s a menu option in Reaper to convert region markers to project markers.

Here is the relevant section from the MixPre-6 II manual:

For PC users, the MixPre-6 II and MixPre-10 II will appear as a 2x2 audio interface unless a specific ASIO® driver is installed. The latest ASIO drivers are available for free at www.sounddevices.com/down-load.

That will explain things. So, yes, it seems we are stuck with 2x2 audio on Linux. I’ve never stopped to think about that because I’ve only ever used it for the 2 outputs. Also, I found my MX-USBY cable that I had bought with the device and completely forgotten about since the one time I had used it. That’s the way to connect from USBC to a USB-A-only computer. D’oh!