Something Wrong with JACK

Hey there,

i worked with ardour for a while with jack routing sound of different outputs to ardour tracks directly. Everything was ok till i tried to connect an AKAI mpk25 as Midi-controller.

I’ve learned that there is a way to route ALSA-Midi to JACK-Midi using a2j bridge.

however, the command:
a2jmidid -e for starting the bridge didn’t work.

dimooooon@dimooooon-Presario-CQ61-Notebook-PC ~ $ a2jmidid -e
JACK MIDI <-> ALSA sequencer MIDI bridge, version 8 (7383d268c4bfe85df9f10df6351677659211d1ca) built on Thu Jan 1 01:00:00 1970
Copyright 2006,2007 Dmitry S. Baikov
Copyright 2007,2008,2009,2011,2012 Nedko Arnaudov

Bridge starting…
Using JACK server ‘default’
Hardware ports will be exported.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
ERROR: a2j_jack_client_create: Cannot create jack client
ERROR: a2j_start: a2j_new() failed.

i tried out different ways to setup the jack. tryed jackd, jackd2, nothing worked.

so i just can still use ardour with ALSA but jack doesn’t work anymore. there always the message “could not reconnect to audio/MIDI engine”

I’m sure that i actually broke jack by myself so I tried to reinstall jack for load default. but it didn’t work.

actually i see just reinstall my whole linux to get jack to work like it did just a few days ago.

could you please tell me how to get JACK to default without reinstall linux?

ps.: SRY MY BAD ENGLISH im German guy with russian roots XD

See for how to set up a working jack.
If you’re using QJackCtl you click the Setup button, select the Advanced tab on the Settings tab and make sure the Output and Input devices are set to something that makes sense.

I also suggest you start jack first and then a2jmidid

I’ve already tried every think. Even a new kernel. I think i’ve figured Out where the troubles come from. There ist Something wrong with dbus itself. Its Not even possible to Connect Carla, lmms or whatever to Jack . There ist an Error All the time.

Maybe i have to try some other Jack Controller AS the qjackctl. Something Like cadence.
As i learned there ist a buildin alsamidi2Jack Option in cadence

What happens if you start jack yourself and instead of using dbus?
Run something like this in a terminal

jackd -r -dalsa -dhw:0 -r48000 -p1024 -n2 -Xseq

Even if it doesn’t work the error message should give a hint where the problem is.

please note that -Xseq should never ever be used with Jack2 (the version installed by most Linux distributions). The timing is unacceptable (lots of jitter).

@Dimooooon: After starting jack, assuming that jack works, try simply a2j -e instead of a2midid. The a2j -e works in my environment perfectly. I use JACK2 (jackdmp 1.99). I hope that works.

Hey thanks for so much answers (y)

There ist a litle Update:
I’ve installed kx-studio with Carla as the Jack Controller. And and at the first look I feel Like "oh nice, everything Works quit perfekt. " But later came the messege Like " there ist an internal Error . Do you want to send a Report? " and the GUI of the KDE didn’t Response anymore.

It was because of Carla. (I’ve read tons of forums about kx-studio and Carla)
As next step i Just installed The Ubuntu-Studio.
There is the qjackctl and a2j build in. And …

I actualy don’t know why but in this destribution the
Jack works AS Well AS a2j. Everything works .
Im just happy xD

Do you have a reason to use JACK, rather than Ardour’s own ALSA backend?

I am no expert but appears to me a2j is just a script wrapper (see so there’s no fundamental difference between running a2j or a2midid. In other words, a2j might not have been what fixed the problem.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.