Some VSTs not sounding until preset reloading

Hello, some months ago I tried to use Helm VST on Ardour 5.12 on Windows 10 64bits. And every time I opened a session the Helm tracks didn’t sound until i re-loaded a preset in it (even though it saved the state, it didn’t make any sound). This made really annoying working in tracks with various helm instances, but I thought it was a Helm related problem so I uninstalled it and stopped using that plugin.

Now the exact same problem is ocurring with “Xpand! 2” VST by AIR software. I have it legally but it get the same issue that happened with Helm: It works fine until I save the session, then I reopen and none of the Xpand! 2 instances make any sound until I reload the presets I’m using. The knobs and configurations are there saved with the session but the plugin doesn’ sound and this is really frustrating and time consuming when I have various instances of the plugin (I use Ardour for beatmaking so i use a lot of virtual instruments).

Didn’t know where to post this so I posted on the windows category.

If someone could help would be awesome, also if you need more information about my setup or so just ask, I don’t know what else could be relevant to the case. Cheers!

In short: this should be fixed in Ardour 6.

There was a bug in Ardour 5.x that the order in which VST plugin parameter VST presets are restored was undefined. As long as you’ve never selected a VST preset in the plugin all should be fine. But after selecting a preset, on the next load the state was not restored correctly.

1 Like

That’s great! Is this response refering the presets that appear in the Ardour window of the VST, or the presets INSIDE the VST, or both?

Hello again, today I downloaded Ardour 6 for Windows 64bit. I was hoping this problem to be fixed but to my surprise it turns out that the exact same problem is occurring in this version. I opened an Ardour 5.12 session that uses the mentioned plugin (Xpand! 2) and it won’t sound until I reload the presets in every single instance of the plugin (REALLY annoying). I reloaded the presets and then saved the session with the new Ardour version and re-opened to check but it still has this issue.
Any idea of what could be happening here?
Thanks for reading.

bummer. There have been reports that this was fixed for other VSTs, perhaps there’s something special about Xpand 2? Are other VSTs affected, too?

Yes, now I checked that it’s also still happening with HELM. Those were the 2 plugins that I had problems with. I also created a new session and tried but the issue is still there with the 2 plugins. Don’t know what could be.