[Solved] Working With MIDI Hardware (Korg Minilogue XD)

Hey there, I was just wondering how one would get a MIDI hardware device working with Ardour. Specifically, I’m using a Korg Minilogue XD, and I’m trying to get MIDI to and from it, as well as syncing the MIDI clock with it, ideally syncing it from Ardour to the device.

I’ve managed to get audio recorded from the synth, but that’s the only thing I’ve been able to get.


I had a quick look at the manual:

First step is to connect the device to your PC using USB.

The Korg should show up as MIDI device in Ardour’s Menu > Window > MIDI connections. – if not, check Window > Audio/MIDI setup – what OS are you using?

In the MIDI connections window, connect “Ardour/Misc” Sync > MIDI-clock out to “Hardware” system:… (midi port corresponding to the Korg)

Last but not least: in Ardour’s Preferences. Sync > MIDI > Enable Mclk (MIDI beat clock) generator.

The Korg must be set to use “Auto (USB)” as clock-source, see page 41 in the manual.

Press “play” in ardour, and the Minilogue should pick up the BPM.

To record MIDI, create a MIDI track, it should auto-connect to first available MIDI port, if the Korg is not the only MIDI device, you may have to manually change this.

You may also want to disable the preference: “MIDI” -> “MIDI input follows track selection” (to avoid accidental disconnects).

Anyway, I’ll keep my fingers crossed. If it doesn’t work, it’ll be helpful to know what you’ve tried and where you’re stuck.

1 Like

Thank you for the detailed reply!

To answer your question, I’m using linux - specifically Arch Linux. Generally my setup is to use JACK2, and I use Cadence to start it. When using Bitwig Studio (I mention this only because I can get MIDI in + out using it, proving it -can- work) I don’t run a2jmidid, or use the ALSA midi (it doesn’t work with Bitwig).

With Ardour, I’m not sure if I should be using ALSA for the MIDI or a2jmidid.

As of right now, I cannot get my Korg to show up in the MIDI connections window.

Does it show up with amidi -l ?

Unless you have a good reason to use JACK (e.g. inter-application rounting), I highly recommend to not use JACK but ardour’s native ALSA backend. That is a lot simpler to get started with, especially with MIDI.

1 Like

It does show up with amidi -l.

I’m not quite sure why I’m using JACK, as odd as that sounds. I was under the impression that it was kind of a standard for doing pro-ish audio. I’ll try right now without using JACK.

Edit: Addendum - I use PulseAudio so I think that’s why I was using JACK. AFAIK ALSA -> Pulse gives you latency or something to that effect. Keeping in mind this is just like, years of various fiddling with Linux audio that I’m basing this on. Half remembered forum posts and the like, lol.

That’s great. So you mostly need to get Ardour’s MIDI I/O going…

heh, The Internet is full of outdated and/or misinformation… :smirk:

Ardour/ALSA will require exclusive access to the device (and not allow other applications to use the soundcard). In a pro-audio setup that is usually preferred, nobody want desktop sounds to bleep from studio monitors anyway…

Compare to:

Audio System: ALSA … MIDI System: prefer ALSA Sequencer.

Latency and performance wise this equivalent to using JACK which also uses ALSA under the hood, (performance wise it’s actually a tad better than JACK).
The main reason to prefer JACK is to allow other applications to use the soundcard at the same time, however setting JACK up proper, and configuring MIDI for it is a non-trivial task. With jack2 there’s currently still no way to avoid a2jmidid -e.

In any case, I’d postpone JACK for the time being…

1 Like

Ahhh, I think this is why I was doing it - mostly for being able to watch YouTube tutorials and the like while working on things.

For now, I’m attempting the ALSA setup:

MIDI Settings:

MIDI Setup:

MIDI Connections:

So even enabling all of those in the MIDI connections panel, it doesn’t seem like the tempo is getting locked on the synth - when using Bitwig and locking the tempo, if you attempt to change the tempo, it reports on the synth LCD screen that it’s locked.

Edit: Another odd thing is that when looking at Hardware as a destination, it shows minilogue (Out), and when looking at Hardware as the source, it shows minilogue (In):

Click on the square in the matrix “Midi clock out” -> “miniogue XD (Out)” to make the connection. A green dot will appear to show connected ports.

over here it looks like

1 Like

Aha! Based on a hunch, I pressed play on the transport, and suddenly, the synth reports “Ext Clock”.

Looks like it works. A bit strange that it only runs when the transport is going but I suppose that makes a certain kind of sense.

I guess this can be called solved!

If I’m ever in Berlin, I owe you a beer! :beers:

1 Like