[SOLVED] Transfer/recover old plugin settings to new plugin versions (LSP)

Hi guys,

I want to continue work on a project from a few months ago… Now I’ve got all the latest versions of everything installed - and Ardour can’t find a few LSP plugins (LV2) anymore, unfortunately…

I found that since LSP Plugins release 1.1.10 is ready! “Plugin names now have ‘LSP’ prefix for the LV2 format.”

This could be the problem, as the plugins that cannot be found now still have the old names, e.g. my old project still got “Graphic Equalizer x16 MidSide” - which is most probalby the old version of same plugin now called “LSP Grafischer Entzerrer x16 MidSide”… And I found that I still got LADSPA-plugins with the old names installed today…

So: Is there a way to recover/transfer the saved settings of the old plugin instances to the new/current plugins…?

Thanks a lot!

Ardour seems to store the state of LV2 plugins in the plugins subdirectory of the project folder. I’ve never tried it myself but copying parts of those .ttl files might do what you need. However, It seems like a lot of hassle and if it were me I’d just finish up those projects with the LADSPA versions you still have installed. The other option, asssuming modest number of plugin instances, is to just screenshot the settings and re-apply by hand.

If the problem is simply not being able to see those LADSPA versions (maybe not given the name change), uncheck the option under preferences–>Plugins:

Someone else might have a better idea…

LV2 plugins are identified by URID. The LSP prefix in name should not matter. I believe you have some other troubles with LV2. Does the plugin bundle work for your new projects?

1 Like

Thanks for your kind help!

I looked through all those files in the “plugins” folder, but unfortunately I cannot find data of those greyed out plugins. It seems only a part of the used plugins is stored there…?

I’d take both options happily, but I can’t find a way to access the greyed out plugin instances. Do you have any idea how to get to their settings…?

Hi Vladimir,
thanks for answering!! The plugins work well (both LADSPA and LV2). Maybe I had the plugins installed manually in the past (via binary from your homepage), right now I use the KX-studio-repo-version. Could this cause this problem?
Thanks a dozen!

I believe there could be a conflict between two versions of libraries. But can not say it for sure.
Do I right understand that now all works fine for the latest version from KX Studio repository?

SOLVED!

After playing around with the plugin settings and rescanning for plugins etc. the plugins appeared again: They appear as VSTs now, what is strange because I never ever use VST if I have a LV2 version, but maybe/probably I made this “mistake” when creating the files… However, they show up, they open, they work - I can go on…! Thanks so much for all your kind help and time!!