[SOLVED] Samplv1 drumkv1 synthv1 padthv1 - no gui in Ardour


(roithamer) #1

Hello
This is my first post so I just want to salute all of you guys responsible for giving us this great great great DAW!

Anyways, I’ve got this problem with samplv1 - lv2 plugin (also padthv1 and synthv1). Basically regular gui does not work - there’s only big blank gray empty window with: pinout (none) add save delete etc at the top of it. Generic Ardour’s gui works just fine but still.

I’m using Ardour 5.12-7 and Samplv1 0.9.3-1 both from community archlinux repos.


(Robin Gareus) #2

One issue may be related to the UI-type and can be worked around as described in

http://www.rncbc.org/drupal/node/1918#ardour

in short run

sudo find ~/.lv2 /usr/local/lib*/lv2 /usr/lib*/lv2 -name "*v1.ttl" -exec sed -i 's/drumkv1_lv2:ui,//' {}\;

However this could also be a deeper issue. The vee-one plugins are not self-contained and rely on system-wide libs. These may conflict with libs that other plugins use (e.g. QT4/5 cannot co-exist). There is no solution to this.


(roithamer) #3

Yes! That was it. Thank you Robin!