[Solved] Q:Time Signature regression in 7.x? A: No

Hi I was just starting a new song in 6/8, and I’ve run across what looks like a regression since 6.x.

When I set Time Signature with the TS: button, I can change Beats per bar to 6.00 and Note value to eighth, and it does change on the Time Signature ruler, but the TS: button still shows 4/4 and the metronome counts 4/4.

I have changed MIDI->Session->Allow non quarter-note pulse. It also makes no difference whether I select Edit Tempo->Pulse->Eighth

Is it just me? Is it just a known evolutionary blip in the new timing system? Should I Should I just revert to 6.9 for the time being? Should I file a bug report or might this be related to 9066: bbt ruler is incorrect…?

Thanks

For what is worth, I could not reproduce this (in Linux, version 7.1). It all worked as expected in a brand new session.

Is this a session you started in Ardour 6?

Curious. No, it was a brand-spanking new 7.1 session (and 7.0 and 7.1.85 nightly). Things worked as expected in 6.9. I thought it odd that I hadn’t seen any other accounts of this. Thank you for checking.

I’ll fiddle around a bit.

…3 minutes pass…

EDIT: Bloody 'ell. I rebooted my machine and now it works. :thinking:

Thanks,
-Manuel

…15 minutes pass…

So evidently the problem arises when I use a particular session template that I’ve been using since at least Ardour 5.x (which just connects Master bus to my preferred outputs). The session starts with start-end location markers at 0:0:0. Maybe that’s causing problems with the new time system(?), but the solution is simple enough. Thank you @finotti for the sanity check.