[solved]Problems with samplv1 plugin

(DeepSynthSound) #1

Hello,

first of all: I do not use a DAW for a long time. so please be patiently with my questions :slight_smile:

I’m using Ardour 5.12.0 on a Linux Mint 19.1 (Cinnamon) System. I have conneted an old MIDI Synth via the Beringer UMC204HD Interface.
It works fine. I can record and Play Audio and MIDI.

I installed the “samplev1” plugin. I can see the GUI of the sampler an I can load samples. Also i can see the green MIDI LED lit, if I hit a Key on my synth. This works.
But, i can hear any sound. If I opens the sample-sound in a wave player, I can her it. that works too. The mixer panel-meters show also an action if I hit a key an my synth or the MIDI Track (piano-roll) in the editor.

The “samplev1” sampler should play the sample, if I hit “C4”. (I have tried all Keys :slight_smile: )

So, why i can’t hear any sound? Do I have to connect the output sound of the sampler-plugin virtually in Ardour with the UMC204HD interface?

best regards
Florian

(roithamer) #2

Check In/Disk buttons in the mixer strip of this track.
Also, do you have any sound from this track if you replace samplv1 with some other instrument plugin (like a-reasonable synth)?
You can also try different sampler (lsp sampler?)

(DeepSynthSound) #3

Thanks for your answer!

I toggel the In/Disk buttons, but there where no success.

With the “a-reasonable synth” I can hear also no sound. I think there is a main problem, what have nothing to do with the plugin, right?

I’m using “ALSA” at Ardour startup. Maybe is this a problem?

Edit:
I can remember a question while the Ardour installation: I was asked for the monitoring variant. I chose “no monitoring”, because i use an external mixer. maybe is this a hint?

(Robin Gareus) #4

OK, so there’s some other issue. Does audio work in general? I suggest you follow the signal path: Input -> midi-track w/synth -> master-bus -> Output and check signal level meters along the way to see where it stops.

Also, does playing the plugin directly work? (in case of a-reasonable synth, open its plugin UI, there’s a MIDI-keyboard there – or in the editor, increase the height of the MIDI track and use the keyboard in the track-header)

(DeepSynthSound) #5

I can see activity at the “MIDI level meter” (MIDI 1 - Track) if I hit a key on my external synth. There is also activity at the “master level meter”. And the level meter to the left of the buttons “mixer” and “editor” shows activity.

If I play the GUI-Keyboard of the “a-reasonable synth” there is also activity at all the 3 level meters. But no sound.

I’ve watched many youtube-tutorials, but I can’t find any hint to my problem. Do I have to connect the output of the synth-plugin manualy to an audio output?

(Robin Gareus) #6

OK, so this isn’t a synth issue per se, but you don’t get any sound at all!

Either master-bus output isn’t connected or Ardour is not using the correct soundcard, or the issue is further down (speakers/headphones, amp).

  1. Check the master connection. Usually 1+2 are Left/Right of the soundcard

  2. Check Menu > Window > Audio/MIDI setup – what soundcard are you using for output?
    To further diagnose, run the following in a terminal window:

cd /tmp && wget https://community.ardour.org/files/adevices.sh && bash ./adevices.sh

It will list all soundcards, their current settings and applications using them. That may shed some light.

(DeepSynthSound) #7

Hy Robin,

thank’s for your help! With your hints and ideas I found the solution. At the end my problem was very simple :slight_smile:

I’m using a Beringer UMC204HD USB-Audio-Interface. At the startup-window of Ardour there was the internal soundcard of the mainboard selected. Not the USB-Interface.

With LMMS it works perfectly out of the box. So i don’t realize the problem with the wrong sound-card interface. All level meters shows activity. I thought it has something to do with the output-matrix. I was on the wrong track :frowning:

Now the “samplev1” plugin works. But only with the “a-reasonable synth” as input. So I trigger the “a-reasonable synth” with my external midi synth and the “a-reasonable synth” triggers the samplev1 plugin. The “a-reasonable synth” is muted.

Thank you very much for your help!

best regards, Florian