[Solved] No Sound coming from Samplv1 - LV2 Sampler Plugin with Ardour 5

I’m not getting any sound output. Tried running the sampler Samplv1 (a polyphonic sampler) as a plugin in Ardour 5.

The sampler is installed and connected through a midi track. Also, a sample is loaded which was checked to playback without any problems.

Still, there is no sound when triggering the note (image step 1). I get a signal in the meter (step 2) and also, midi in led lights up in the sampler.

Just to test the audio I’ve also inserted amsynth (see step 3). When this is triggered through a midi signal, it plays an audio signal.

Still, I get no audible sound coming from the sampler. Any suggestions on how to troubleshoot further?

Remove “amsynth”.

Have a closer look at the box that you’ve labeled (3). The audio outputs (green pins) of synthv1 are not connected. Only MIDI (red pin, red wire) is.

1 Like

It finally worked, the solution is as follows:
When adding the new track make sure to select Pin Mode: Flexible-I/O

If you can’t select Samplv1 as an instrument in this window - choose none.
You can then add Samplv1 through the plugin manager.

Happy sampling :sunglasses::desert_island:

You don’t need flexible-I/O here. Synth plugins can always add/remove ports
(although in some cases instruments are not properly detected, in which case you’re right – but the vee-one plugins shouldn’t need it)

Strict-I/O means that effect plugins cannot add/remove ports. e.g. when adding a stereo plugin to a mono track. With strict-I/O the mono track would remain mono.

PS. You can later toggle this in the mixer-strip’s context menu (right click on the colored bar top of a mixer-strip), or override it in the plugin pinout.

For some reason the sampler doesn’t play any sound if I choose Strict-I/O. For whatever reason … it works and I’ll take the solution.

The process of manually adjusting the pin configuration is also described here:

Thank you for helping out :desert_island::sunglasses: