[Solved, no bug] U-he Runciter only has sound in channel 1

Hi, when using the U-he Runciter plugin (win/mac/linux demo here: Uhbik: Nine subtle to spectacular effects | u-he), I only get sound in the left channel. I’ve tried to change the pins in all possible configurations, but no matter how it’s configured, only one channel is being processed. According to the manual, the plugin should process channel 1+2 if you right-click in the panel and select “1+2”, but it doesn’t. The only way to get any sound out of channel 2 is to select “mono-surround”, but then it seems to only process channel 1 and send it out to both channel 1 and 2.

I’m using Ardour 6.0 on Linux. Maybe this has been fixed in a later version? Unfortunately I’m not able to install latest version of Ardour on my old Linux laptop.

Radium behaves the same way as Ardour, except that channel 2 is bypassed instead of muted (which is also really weird). Radium uses JUCE to host VST plugins so it should do the right thing. This is really strange.

Does anyone use the Runciter plugin? It seems highly unlikely that the Runciter plugin should have a big bug like this, but I don’t know. I can’t find anyone else reporting about this problem with Runciter.

(I’m the author of Radium, and this is originally a bug reported for Radium on Mac, but it seems to apply for Radium on Linux and Ardour on Linux as well. If it even is a bug, I don’t know what happens here.)

It would surprise me if you couldn’t install 6.7 from this website on your laptop honestly, why do you think you can’t?

   Seablade

Here’s an update: Runciter works in Reaper! So this seems to be a bug in both Ardour and Radium.

It would surprise me if you couldn’t install 6.7 from this website on your laptop honestly, why do you think you can’t?

I think I can’t because my glibc is too old.

If anyone can confirm that this bug is still present in Ardour 6.7, I’ll add a ticket to the bug tracker.

Just insert the plugin, and if right channel is muted, the bug is still present.

I have been using U-he Runciter since Ardour 5.12 until the current version without any problems. No channel is muted and everything works as it should.

So I assume you also use the VST2 version of the plugin (not VST3) is that correct?
Which version of the plugin?

Are you adding it to a stereo track?

On Mono tracks Ardour will intentionally only connect and use the left channel and inform the plugin about that.

Unlikely. Ardour still builds with gcc-4 and we provide versions compatible with Ubuntu 2008.04 at https://nightly.ardour.org/

I just checked with Uhbik_131_8256_Linux.tar.xz and Ardour 6.7: works fine there is a signal on both channels with the VST2 plugin:

1 Like

Ouch, yes, I’m using a stereo track, but there was an a-compression instance in the plugin chain, which outputted only left channel. Sorry, no bug, my fault. Shouldn’t have used an old project to test with.

When running the installer, I first get this:

Then there’s a billion messages like this:

And the final messages are:

libvmec.so.1 is a part of glibc, but it was introduced in a later glibc than I have. Perhaps I could compile libvmec manually though.

Thank you, the gcc-4 version of the nightly build works.

I have 5.12 too, but the surround panner popped up when inserting the runciter plugin, probably because it has 8 output channels, which made it harder to figure out exactly which outputs that had audio, and whether they were muted or bypassed. So I just used 6.0 instead.

I tried now manually compiling and installing libmvec.so.1 before installing the gcc5 version of Ardour 6.7. When running the ardour installer, it didn’t complain about the missing libmvec.so.1 file this time,[1] but the installer still gave the error message “!!! ERROR !!! - Missing library detected!” at the end and didn’t install anything.

However, when I gave the “–keep” argument to the installer, the program did actually start when I ran it from the temporary location, so you seem to be right, I don’t seem to strictly need a newer version of glibc to run the gcc5 version of Ardour 6.7, except for having to manually install libmvec first. Lots of built-in plugins are missing though.

Feel free to email me if you want to fix this in the installer and you want me to test again on my ancient computer. :slight_smile:

[1]. The installer didn’t check my LD_LIBRARY_PATH environment variable, so I had to manually copy it into my system library folder.