SOLVED: Mp3 files exported from ardour 6.5.0 skip when played on iphone

EDIT:

TLDR: Make sure to export MP3s to be played on iphone/ipad/ios in Constant Bitrate (CBR). There is a setting in the export edit screen to change from Variable Bitrate (VBR) to CBR. You want CBR if you want to avoid the skipping mentioned in this post. CBR at 192 kbs did the trick for me, as suggested by the experts in this thread.

Further, I would like to note that this is not an error or defect in Ardour. No, ardour’s default MP3 export is set to VBR, and the users need to know what settings they need for the hardware they are using. There is tons of information about VBR and CBR and from what I can tell from researching after this experience, any benefits of VBR are outweighed in the fact that many hardware and software systems choke up on VBR for all kinds of reasons. This is why the file would only choke on ios. It was a VBR export. Once I changed it to a CBR at 192, no skips, no problems. Thanks for helping me solve this frustrating problem. Finally, I would like to note that I repeated the solution in audiacity. Indeed, the default export setting in audacity was also VBR. When I took the same .wav file from ardour and exported from audacity at same CBR 192, it was perfect and produced a file the exact same size as ardours file, which makes sense because they both use FFMPEG as the converter. Thus, it is not a problem with ardour, but with a conflict between ios playblack and use of VBR .mp3s. To avoid, use CBR.

Thanks.

Original post:

Hello. This is a strange one.

I record a session in ardour. If I export to a .wav, it plays on all hardware no problem. So for instance, it plays through my mac, on my linux box, on my iphone, etc., without any skips.

Now, when I export the session to any .mp3 format through ardour, it still plays beautifully on all the hardware-- EXCEPT for the iphone. So each time the .mp3 starts on the iphone, there is a skip of a several seconds, and it happens a few times. Only in the begining of the track, like the first 10 seconds. So, if I play the .mp3 on my mac, through itunes or quicktime, it works fine. on my linux box through any media player fine. on my iphone, skips.

OK, here is the very weird part: so i figured i would try to outsmart the system. i took the .wav export of the session, opened it in audacity, and then, in audactiy, saved the .wav to a .mp3. because i presumed there was a problem somehow with how ardour is making the .mp3. well, same exact problem with this .mp3 file. this happens on any .mp3 file that is created either from an ardour session or a .wav of an an ardour session, ONLY on iphone playback. the only way i can get an .mp3 that does not skip is to import the .wav (which is the mastered session file) into garageband, and then export to .mp3. if i do that, it does not skip on iphone.

here is the problem with this issue: its bad for sending files to others who use iphones. you never know if your .mp3 will skip. it may be a problem with apple, but somehow, ardour is triggering it. it only happens with sessions created on ardour. does not happen if i create my mix on garageband and export to mp3 or if i import my ardour .wav to garage band and export to .mp3.

the skip is similar to the old days of CD players when you woudl accidentally shake the player and it would skip. also, important, the .mp3 plays just fine on any other hardware. this only happens on the iphone playback.

i have also just reported this issue on the bug tracker. issue # 0008571.

any help or ideas?

thanks so much,
a dedicated ardour fan

edit: iphone Xs Max, software version 14.3; new - able to repeat also on an ipad

First question…have you checked to see if this happens on other people’s iPhones and not just yours? I make MP3s direct from Ardour for my wife’s iphone all the time and I never hear complaints about skipping. That’s on Linux though and I believe Ardour on Mac uses an Apple library for MP3 creation.

Second question, are these mono or stereo mp3s? Quality? Variable or constant bitrate?

Perhaps try https://www.freac.org/ on your Linux box to convert the WAV to MP3…

Ardour isn’t the problem since you’re getting the same error using Audacity.
The problem seems to be that your iPhone doesn’t like the mp3 encoder or the mp3 encoding settings that Ardour and Audacity are using.

Garageband appears to be using either a different encoder or different settings.

Make sure Ardour uses a constant bitrate and that it doesn’t place any tags in the mp3.
With a bit of luck that’ll fix your problems.

1 Like

There are various reports on the net:

sadly none of them mentions an actual solution. @peder 's suggestion to try using a fixed bitrate, perhaps not too high can help. Might be worth comparing the files and see what garageband produces.

first question: no i have not, but it did happen on both an iphone and an ipad, as i added in the edit.

also, i should note that i use ardour both on linux and on mac osx, although there was no choice for that in the post (i had to pick one OS). i use both and strangely i have confirmed the mp3s created on both systems do the same. again, the mp3 files run fine on all other hardware, just iphone and ipad repaly cause skips in the first few. i see that paul posted reports related from web and will check and reply.

now you might ask why do i think its ardour triggered. because i constnatly edit songs and mix down mp3s and then listen to them on my iphone. i use ardour a lot for this and it got to the point where i only will export .wavs from ardour (for this purpose) because they dont skip on the iphone. so if i use garage band instead, and i export to mp3, no skipping, i’m sure its an apple discrepancy but it would be good to figure it out so that there is no fear of sharing a song on .mp3s when so many folks use iphones. not complaining. i get how many levels of screwed up ios software or hardware this could be. but something simple is triggering it only on ardour mixes. or should we say only on mixes that are made with the mp3 engine used by ardour. thx

second question: export set to MP3, session rate set to 44.1khz. inside “edit” options it says FFMPEG/MP3 options VBR 140-185 kb/s, smaple rate conversion quality set to: best (sinc), no pre-process, no watermark, no metadata fields, no post export processes. as four mono or stereo, dont see an option for that, but there are stero tracks in the mix. the master track of the final mix is stereo. thx

hello. regarding your suggestion to try a constant bitrate, i pasted in response to @bachstudies the following attributes of the export. does this indicate constant bitrate? thanks!

export set to MP3, session rate set to 44.1khz. inside “edit” options it says FFMPEG/MP3 options VBR 140-185 kb/s, smaple rate conversion quality set to: best (sinc), no pre-process, no watermark, no metadata fields, no post export processes. as four mono or stereo, dont see an option for that, but there are stero tracks in the mix. the master track of the final mix is stereo.

thank you. i read about the other complaints and for a while withheld from posting this because i thought it was just apple. but the thing is, becuse i use both ardour and garageband so much, i use enough mp3 files created on both, and in other places, to realize that it is only happening with ardour mp3s. so i wanted to let you guys know. i never had the problem with any other audio on iphone, despite the related reports, so i think this is different. and since it happened on audactiy, then perhaps in my non-expert mind it is the manner in which the mp3 creation engine being used by the programs, which i think is the same for both, is interacting with the iphone system. not saying its anything that is ardour’s fault, just helping to let you know and see if your expert minds could figure it out. thanks

if im not mistaken, both audacity and ardour use ffmpeg as the mp3 conversion engine. so i guess what i am trying to say specifically is that i believe my experience shows that mp3s created with this engine are subject to the skipping problems when replayed on iphone and ipad (ios) devices. dont know if this is true, but it has happened ot me enough times to let you know about it and i have taken the same .wav files and converted them to mp3 in garage band and they do not skip. it would be interesting to know the differerence in the files. thanks again for all you do

Try CBR 192 kb/s (CBR = constant bit-rate, VBR = variable rate).

Thumbs up. Will try and report back.

Doing tests now but wanted to advise you that the audacity default export was also set to a variable bit rate. so you may be on to something good. i have now exported .mp3s at 192 CBR and will report back later today after listening to them several times. thank you!

confirmed solution and edited original post to as solved and to explain solution. also added note to my bug report #0008571 with resolution. not a bug. thanks very much

you were right. i updated the original post. thanks

correct you were! i updated the original post to describe the solution. thank you

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.