[Solved] Monitoring problem


(rogerbx) #1

Hello everyone,

I’ll will try to explain the problem I have with monitoring.

I would like to let Ardour handle the monitoring but the sound I get during the recording process is far different in comparison to the sound I get after playing back the recorded track.

The recorded track nevertheless sounds the same I get where I setup ardour and the sound cart to the achieve Hardware Monitoring. This sound is correct.

I am recording to a PC thru a Prodipe Studio 22 Pro sound card. The PC is running Ubuntu 14. I am using headphones, the master on the sound card is off, and the Mix is turn to ’out’ what meens that everything in the headphone comes from Ardour.

The ardour version is 5.12.0. The problem is the same with version 4.

The Ardour setting is :

  • Signal Flow > Record monitoring handled by Ardour,

  • Tape machine mode on/Off makes no différence

  • The transport Auto Input is On

The sound I get is like distorded, or like the recorded track is running twice at the same time with a very little latencie in between.

Do you have any idea what to do to solve this ?

As a solution I could use the hardware monitoring but I would also like to monitor the plugin effects while recording.

I thank you in advance for your help.

Best regards,

Roger


(Seablade) #2

And you likely just hit it, the plugins.

It can depend on your exact settings but there are two points I think might cause this, one is that even though visibly it seems that the audio monitoring is off in the sound card it might still be processing audio, check this by shutting down Ardour (And any software) and seeing if you hear audio th rough the monitoring.

Second possible issue is you have multiple tracks, and especially busses, that are pulling input from your sound card. Busses especially are not latency compensated, but I am not sure that latency compensation will affect live procesing of audio through plugins anyways on tracks, maybe someone else can comment on that.


(rogerbx) #3

Hi SeaBlade, Thanks for your answer.

I tried what you suggest. Lived Ardour even Jack. Sound card master still Off, If the Mix pot is on t(he “Out” position (monitoring by software) I don’t hear anything in the headphones. If I turn it to “In” the sound comes back. Thus I lived it on “Out”.

Starting Ardour again. New session, only one audio track connected to the input mic. No plugins. The problem is still the same. The recorded audio sound is not the same as the monitored one.


(rogerbx) #4

Hi everybody and happy new year.

I am coming back with my monitoring problem. I have may be an explanation, but I don’t know how to solve this and how the other musicians do.
I am playing diatonic harmonica. So when I register with headphones I still hear the instrument thru the headphone. So I hear two sound sources for my instrument, 1- the direct sound, 2- the monitored sound. It would be surprising if the two sounds would be perfectly synchronised.
Is there a way to solve this ? Is there some latency setup I am missing/don’t understand ?


(Mikael Hartzell) #5

If your sound card can route mic input to your headphones, then use that because there will be no latency at all.

Then tell Ardour you don’t want it to route audio from the recording track back to the audio interface while recording:

Edit / Preferences / Signal Flow, then change “Record monitoring handled by”: Audio Hardware


(Seablade) #6

@mhartzel

While this would normally be the correct answer, the OP mentioned he wanted to monitor with plugins inline.

@rogerbx

In order to monitor with plugins inline you will need to stop your audio interface from handling montioring, sadly there is no single way to do this as it varies depending on the interface/sound card manufacturer. At first glance your original description seems like it should have done this but your latest post suggests that it has not. It is not out of the realm of possibility you cannot do this in Linux due to a bug, but I would definitely spend time in alsamixer to ensure that the hardware monitoring is off without Ardour open first.

If you can monitor without plugins as mhartzel suggested the best way to do so is to turn off monitoring in Ardour per his instructions.


(rogerbx) #7

I tried hardware monitoring and it worked perfectly. I hear the natural sound in my harmonica in the headphones without any latency.

With software monitoring the problem does not come from Ardour I suppose.
It comes because my headphones are not enough “soundtight” and thus I can hear the natural sound thru the headphones and this sound is mixed with the software monitored sound when I am recording. And the software monitoring has a little bit of latency with the natural sound.

Like I wrote previously it’s not a problem of plugins, the same occurs with a new session and a single recorded track.

I suppose this issue comes for everybody who want to record his instrument thru a microphone with the backing track played just in the headphones.


(Seablade) #8

If it is a case of natural sound leaking into headphones, what headphones are you using? It could be you are using the wrong headphones (Open backed vs closed) for your needs.

    Seablade

(rogerbx) #9

I am using these one https://www.thomann.de/fr/audio_technica_ath_m50_x.htm . It’s a closed one.


(rogerbx) #10

I solved this problem. It’s a question of latency setting with Jack. The JACK setting gave a latency 21.3 ms, I reduce the latency to 5.33ms and the problem is gone. A lot more xruns occurs but that’s another question.

I thank you for your support.

Roger


(Mikael Hartzell) #11

You have just found out why there still is a market for hardware digital and analog effects :slight_smile: A computer can never beat the reliability and low latency of a hardware effect :slight_smile: