SOLVED: MIDI notes present but not visible

Hi! I am new to Ardour and am running into an issue that I think may be a bug in Ardour, but very possibly is just me not knowing how to Ardour.

I’ve recorded some music on Linux with an electronic drum kit, but the notes are not visible. Not during playing, and not after it.

So to be clear about what I’m talking about, I can hear the notes being played, I can play the track back and hear them again, but I don’t see the “yellow blocks” so I can’t edit them. I can import the midi files themselves in MuseScore and it sees them and can play them back.

Here you see yellow bars appearing when unfa plays his keyboard - I get the sounds but not the yellow bars (the actual video is not really relevant, I just wanted to make visible what I am not seeing).

I hope people will have ideas.

Here’s what I tried:

  1. There is only one track in my session and it has only one playlist.
  2. I tried scrolling up and down the keyboard but the snare, for instance, is a D2 “pitch” and even if I make sure the D2 is visible on my left, I cannot find the notes.
  3. If I save the session, then close Ardour and then restart it and open the session again, the notes are still not visible but Ardour still plays them.

If I figure this out myself I will post the solution but to be honest I am kind of stumped.

Maybe the notes are very short? Try to put the “Note mode” on “percussive” (right click on the MIDI header). They should look like diamonds, without length.

1 Like

I have just figured this out, just after you posted that comment and before I saw your reply. But that is in fact what was happening and I might have still been stumped, so thank you so much for that!