Solution for "You have a lock on how much memory..." -warning

Hi there.

I’m new to Linux and Ardour, but after a couple of attempts I’ve got it up and running, real nice studio so far, I’ve worked a lot of years with Nuendo, and this suits my needs for pre-studio work absolutely just as fine. And both Ubuntu Maverick and Ardour is so very cool, I’m a Linux man from now on, that’s for sure.

At first I - like many others - have experienced the warning of a memlock, that might cause Ardour to crash. And ulimit -l said 64, which others also have seen, and which is definitely way too low, regardless of system.

So I followed this webpage instruction:, but it still didn’t work.

I do have the directory: /etc/security/limits.d on my system, so I did as described, made the /etc/security/limits.d/99-realtime.conf
file, but it still didn’t work.

And - here’s the trick that worked for me - then I logged in as root - sudo didn’t work - and copied the /etc/security/limits.conf file into the /etc/security/limits.d directory - copy, not cut - logged out and logged back in as user, and HEEYY, it’s been working ever since. And ulimit -l says “unlimited” like it should.

Don’t know if it will work for you, but I do remember the frustration of being so close and yet so far, so I thoght I’d share it with you.