Snap 'inverted' after update from 7.3 to 7.4

Ahoy troops. After updating from 7.3 to 7.4, the snap toggle is inverted.

What I mean by that is, this is snap OFF;
snap off

And this is snap ON;
snap on

So snap works as normal etc but the indicator shows an inverted status. That make sense?

Anybody else had/have this issue? Seems too trivial to file a bug report for so thought I’d just ask here.

Linux (64bit AMD/Intel) - 7.4 - standard ‘ready-to-run’ programme downloaded yesterday from the main site as normal.

Many thanks and much respect!

FWIW, I do not have this problem in 7.4.

Works just fine for me too. Ardour 7.4 from on Debian 11.6 (Bullseye).

Thanks for the heads up troops. i just tried rolling back to 7.3 but the issue was still there. Reinstalled 7.4 and the issue is still there. Definitely a weird one this…!

There was a kernel update 2 days ago too I think so, although I think it’s a long shot, I may try rolling back to the previous kernel just to see if that was the cause. Otherwise I don’t really know how to troubleshoot it, plus it’s not exactly life or death, so I’ll probably just embrace the quirk and try get on with things as normal.

The kernel should have no effect on how Ardour’s Snap button works.

Have you tried creating a new session, to see whether it’s just the current one that’s having the issue?

Holding Alt reverses the snap behavior, maybe your issue has something to do with that ?

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.