slow graphical interface // ardour 4


i recently installed ardour 4 and have been experiencing a really slow grapical interface. i never had this problem with previous versions of ardour (i’ve been a user for the last nine years).

i’m running debian testing.

my vidie card (from running lspci):
VGA compatible controller: NVIDIA Corporation G72 [GeForce 7300 LE] (rev a1)

has anyone else experienced similar problems or know a way i can get ardour 4 working more smoothly on my system?

any help greatly appreciated.


This is caused by your video card driver not correctly implementing the drawing operations now used in the Ardour GUI. You should check whether there is a newer version of the driver, and consider switching between the nouveau (open source) and proprietary driver to test the result.

thanks for your reply, paul.

i guess i will try the proprietary driver (though reluctant, as everything with this driver has worked fine so far). as i’m running debian testing, i’m pretty sure there is no newer version of the nouveau driver.


another update: i installed the newest version of the nouveau driver (from the experimental repository) but no noticeable change. i will see what else is possible and keep adding updates here for the benefit of anyone else experiencing similar problems.

if anyone else has experienced this or found a solution please let me know. it’s a bit disappointing / frustrating to have waited for ardour 4 only to find that i can’t use it at its full capacity.

we will be adding some methods to test this, and possibly “fix” it before 4.1. the fix isn’t to change what we draw but to a low level tweak to the drawing machinery. we’re not really interested in this long term because using hardware graphics acceleration is sensible, and this would avoid it. but for people with broken hardware/drivers, it will/may help.

thanks again for your help, paul.

just out of curiosity, when you were developing ardour 4, did you try it out with the nouveau drivers? the proprietary drivers, both? i have no idea how software is developed or how the developers approach trying to avoid these problems.

i built my studio computer seven years ago, so i’m sure there are newer, better video cards, and perhaps these are what you developed ardour 4 for?

just for your information, on my lenovo t530 laptop, which is much newer than my studio computer, the video card is an Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09). and here i’m also using the nouveau driver. and this configuration works fine with ardour 4 on my laptop.

so perhaps it’s just a case of my video card being too old (as the nouveau driver doesn’t seem to make a differnce between my two computers).

we ran into people with a variety of video interfaces whose device drivers could not or did not correctly various graphics operations used by ardour/cairo (our 2D drawing layer). We cannot develop for the lowest common denominator unless it is clear that there is so much variation than we have to. This doesn’t seem to be the case here.

I have no idea what my current or previous computers have as their video interface or drivers - they just work, as do all those used by active ardour developers. Some of our beta testers had problematic cards of various types.

My desktop runs nouveau drivers without issue for example. It is a combination of specific graphics chipsets/cards and drivers I believe.


yes, this is the case with my laptop: nouveau driver and nvidia card. this combination works with ardour 4. but on the studio computer: older nvidia card, different chipset and nouveau driver – doesn’t work well with ardour 4.

one of the nvidia test machines where it works fine:

01:00.0 VGA compatible controller: NVIDIA Corporation G98 [GeForce 8400 GS Rev. 2] (rev a1)
linux 3.14-2-amd64 #1 SMP Debian 3.14.15-2 (2014-08-09) x86_64 GNU/Linux
nvidia-kernel-dkms 340.32-1 (debian/non-free)

My desktop machine which has an onboard nvidia chispet had issues with the nvidia drivers back in an older version of ardour 3 which was down to buggy nvidia drivers but noviough worked fine.

ardour 4 on my nvidia gt610 works fine with propriety drivers

one of the nvidia test machines where it works fine: 01:00.0 VGA compatible controller: NVIDIA Corporation G98 [GeForce 8400 GS Rev. 2] (rev a1) linux 3.14-2-amd64 #1 SMP Debian 3.14.15-2 (2014-08-09) x86_64 GNU/Linux nvidia-kernel-dkms 340.32-1 (debian/non-free)

is this machine using a nouveau or proprietary driver?

thanks for your help.

thanks for this information, didn’t put together that a nvidia kernel meant you were using the nvidia driver…

follow up at

thanks, i’ve been following this as well – but no change for me yet. still slow interface with all the daily builds i’ve tried and following the suggestions made on the ardour list.

We have some solid evidence now that it is caused by the version/build of the Cairo library in use. More news when we have it.

that’s great news. i look forward to hearing further updates on this. thanks again for looking into this, ardour has been my main studio tool for years now and i can’t imagine using anything else for recording, mixing, composing.

I know this thread’s old, but in case anybody’s looking for a reasonably priced graphics card that does work properly with Ardour’s Cairo library, I’ve just replaced a GeForce 6200LE based card (which was definitely slow and only slightly improved with FORCE_BUGGY_GRADIENTS) with an MSI card with Nvidia G210 chip and the new one works perfectly. It’s a fanless entry level PCIe card and the best upgrade I’ve had for a while, (though it would doubtless be a disappointment for high-res gamers.)
I’m using Ardour 4.7 on AVLinux 6.0.4 with nouveau drivers and 3.12.19-rt30avl2-pae kernel (built for AV Linux)

Might be a useful data point for someone…

That can be a gradient issue. Cairo is very slow at drawing gradients. Nvidia handled gradient drawing well but other cards caused high performance degradation.
I’ve specially done a couple of job to optimize the CPU utilization by LSP Plugins to not to draw gradients frequently.

The solution for me with a similar issue was the command
nvidia-settings -a InitialPixmapPlacement=0.
This restored near perfect responsiveness (see thread