Simply can't launch Ardour

So …

I’ve tried a couple of Linux distros (AV Linux 2016 x86 and Ubuntu Studio 16.04 X86) .
The problem is that I can’t launch Ardour (Latest version x86) …

On AV Linux I get to the audio options dialog, but then after clicking start it says failed to open audio device (or something like that) … funnily I can’t even start Jack on AV Linux .

On Ubuntu I’ve managed to get Jack started, but the same problem as with AV Linux …
Failed to open audio device .

This goes on with Mixbus 3 also .

Audio H/W ;

Roland HS-5

My PCs a very old HP Dekstop PC .

It is much faster to resolve issues like this on IRC. Web forums suck for configuration support. I suggest you join us there, preferably during roughly 06:00-21:00 US Eastern time.

Are you checking that you have the right card/device selected in JACK with settings that work with it?
Always start JACK BEFORE you start ardour/mixbus. Also, you might try KXStudio instead. From my experience AV Linux was very moody and didn’t want you to do anything other than turn it on and launch ardour.


Please define moody :slight_smile:

Yes with AV Linux as the User Manual explains in great detail the best results are obtained for audio work to select your device in Qjackctl and let JACK and the aloop-daemon do their thing and route everything to and through your selected device. That is the intention, it is not intended at all to be your typical Desktop Linux with PulseAudio and ALSA in charge of the Audio devices, if you have JACK running everything else like launching Ardour or Mixbus (or any other JACK or ALSA programs should be trivial).


If you are the same person who asked the question on the Mixbus forum I answered it there because I read it there first.


Personally I think my laptop and JACK just didn’t like each other when I tried AV Linux. I probably should have highlighted the “my experience” bit a bit more. Anyhow, just a few examples: with multiple programs open (say, Mixbus and Hydrogen or Rakkarack, just for an example) audio wouldn’t work sometimes; plugging in/removing headphones required stopping and restarting JACK or JACK would break until I restarted the PC; other weird quirks like that. JACK never showed any errors or such in the logs either, so it was confusing.

I really loved the concept behind AV Linux, being entirely production focused, and the super low latencies I was getting were awesome.
I know a laptop without a dedicated interface isn’t exactly the intended platform for AV Linux, but until the semester is over my studio is 3 hours away.


I think your problem is the Roland HS-5 isn’t compatible with Linux. It requires a driver for OSX, which is usually a sign that it is not class compliant.