Silence doesn't look silent

First off, I want to say thank you for the work you all have done and are continuing to do on this great program!

I did notice something on Ardour 6.6 that confused me at first. I thought maybe I had setup my gate wrong or something like that, but it is working properly. I thought I had a lot of noise in the recording because that’s how it looks on screen. However, on playback, the parts where I don’t speak are, indeed silent - they just don’t look silent. It is recording properly.

This really isn’t a big issue, I just thought you developers may want to be made aware of it. If you compare the images from Ardour 6.5 and Ardour 6.6 from my Google drive - you’ll see that silence in the recording doesn’t look silent (it looks like noise). Perhaps it’s just from ‘stretching’ the track which I like to do. Here are the images:

Ardour 6.5 silence

Ardour 6.6 silence

Again, thank you for your time and work on this project.

There likely is noise in the signal then. Recording pure silence is near impossible, there is always some low level noise. What does the meter read when you play it? or range-selection → Loudness analysis?

Ardour 6 changed the default waveform-scale to logarithmic, so low noise is more prominently visible. That change was done v5 → v6, not 6.5 → 6.6. This is configurable in Preferences > Appearance > Editor.

Another explanation: 6.6 had a bug where waveforms were incorrectly rendered as silent in some cases (even though there was no silence there). This happened after rec-stop or when writing new data. Resizing the track height made the correct waveform show up in versions prior to 6.6.

The meter is showing zero (no green). The portion in the second image was recorded with mute on.

Cool - I changed the appearance to linear lol. Would a muted recording still show noise? I’m using a USB microphone. Even when I max the volume on my headphones and Windows (muted part) I can’t hear any hiss.

Thank you for the quick reply.

Edited to add:

The microphone level peaks at -55 Db, before the Expander. Monitoring the Output after the Expander shows nothing on the meter.

That make no difference. Ardour records the input as-is. Mute mutes a track’s outputs.

Interesting. I added an edit so you get an idea of the level from the mic.

Thank you again. :grinning:

I just recorded ~ -50dBFS white noise. in A6.6 with Log-scale waveform it looks like:


There’s a gate plugin. I assume you set it to silence low level noise.

In Ardour6 you can do “wet recording”. Instead or recording the input as-is. You could record the signal after the expander + gate. In the context menu of the mixer-strip there’s Disk-IO > Custom.

This will hard-apply the effects when recording making later adjustments impossible. So it should be used sparingly.

Oh thank you. I normally use an expander instead of a noise gate.

In the context menu of the mixer-strip there’s *Disk-IO > Custom

That is probably what I’ll do. Thank you much.

Just for clarity: A noise gate is really an expander with specific settings. Much like a limiter is really a compressor with specific settings. So either a noise gate or an expander could have the effect being discussed here.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.