Shared Library Troubles on Linux (libSoundTouch) [Artix]

Using the latest Ardour pacakge from pacman (6.9-4). Also mainly using pipewire implementations of pulse (though I only know surface level what that implies).

Not sure if shared libraries are the issue here, but I have little experience dealing with something like this. This is the initial error Ardour throws my way:

“/usr/lib/ardour6/ardour-6.9.0: error while loading shared libraries: cannot open shared object file: No such file or directory”.

Downgrading soundtouch lets ardour start, but the audio is poppy and weird. Was thinking the audio might be a clue, but I’m none the wiser on how to fix this. Not sure what debugging information would be needed, so tell me what you information you need if you need it.

Borked Audio

We can’t support distribution-provided versions of Ardour. Please either take it up with the maintainer of the pacman package, or get Ardour from Get Ardour | ardour

There are many potential mistakes that distributions can make when packaging Ardour, and it looks if you have encountered at least one of them.

Tried out the executable installer, the audio is still the same. Here’s another file that shows off the distortion better. I’ll have to do more testing to see what’s causing this. Any leads I can take?

Borked Audio 2

If you’re using JACK as the audio backend you should try and switch to ALSA to see if the sound improves. And switch to JACK if you’re using ALSA
For JACK, try starting ardour with pw-jack -p 2048 path-to-your-ardour-binary to rule out any xrun issues.

Unless you’ve done some weird audio routing in Ardour the problem could very well be in your pipewire setup.

This works, and audio seems to work fine now, but how do I change the sample rate ardour runs at? No matter what sample rate I pass in, it always defaults to 48000, when some files I have run at 44100.


There’s also a -s switch to pw-jack, to change the sample rate, but I don’t know if that works as intended, and it may also depend on your PW version.

Tried -s, didn’t change the sample rate, I’ll do some reading and see if I can get the sample rate to change. I’m curious as to why alsa decided to stop working so suddenly, so I’ll see if I can get that working again if jack doesn’t budge.

EDIT: Now all of a sudden alsa starts working??? Very confusing. I guess I’ll update again if I figure out what was causing it to stop working in the first place. I don’t think I fumbled with anything alsa related while trying to fix this…

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.