Sfizz no sound in Ardour 5.12

Has anyone successfully gotten sound from Sfizz in Ardour 5.12? I’ve tried LiquidSFZ successfully (minus the fact that the =offset opcode isn’t currently implemented) and Sforzando via LinVST. Sound without problems so I’m assuming the issue lies with Sfizz or perhaps some way the plugin interacts with Ardour in terms of pinout. At this point I’ve clicked everything I can and run out of ideas.

EDIT: Tested in Mixbus 6 (+32C) and same issue.

Where did you install Sfizz from?
Can you test with Ardour6? It is working quite well so far. If this is a bug we need to track down the cause.

Can you give me an example of the SFZ files you have loaded into Sfizz?

I installed Sfizz from OBS build for Debian 10 (I’m running MX Linux latest).

My SFZ are hand-crafted from Kontakt instruments. They work perfectly in Sforzando and I hear sound in LiquidSFZ (but the missing =offset opcode means I can’t use that for now). The other issue with sticking with Sforzando is that I can’t drag and drog files into the GUI so useless without Carla (which comes with its own set of challenges).

Check the ardour log, and see if there are unknown opcode entries, or other errors.

Also make a simple test SFZ:

<region>
sample=*sine

Aha! [INFO]: [sfizz] Unknown opcodes: sw_default,polyphony

I need at least one of those for my instruments given I use polyphony to avoid build-up of release samples during a fast trill…So, that would disable the entire instrument?

It seems LiquidSFZ and Sfizz need to add some much-needed opcodes before I can move forward with them. Thanks, @alexmitchellmus!

EDIT: And yes, the simple sine SFZ gave me sound!

However, did the sine test work for you? We need to be sure that it’s not only the missing opcode.

Sfizz is developing very fast with some super features planned for 0.4. (more like a truck load of features)

If there are opcodes that you feel are super important, open an issue on the Sfizz GitHub. However, full ARIA is on the roadmap, so it will get done regardless.

Yes, sine SFZ worked!

1 Like

I visited the IRC for both Sfizz and LiquidSFZ but they as quiet as a quiet thing from quiet land. With regards Sforzando, I’d get by with Sforzando until full ARIA support is worked out in Sfizz but I can’t drag the SFZ into the GUI in Ardour (and don’t know another way to load the file). It works as expected in Reaper for what it’s worth (via LinVST).

There is a discord chat, bottom link on page: https://sfz.tools/sfizz/

If you can post an example of a non-working SFZ it would help narrow down exactly what is going on.

1 Like

Just posting one final message to say that, essentially, this is solved.

As it turns out, within minutes the developer of sfizz added a fix for the sw_default opcode and has given a workaround for polyphony (using < master> to allow < group> to be used at a lower hierarchical level in the patch) until sfizz gains full ARIA functionality (or an intermediary patch is created to allow polyphony as part of < region>).

EDIT: Actually, my SFZ was using a folder structure which was being interpreted by sfizz as absolute from the root directory (as it should!) but that Sforzando was able to interpret (quite loosely) as relative to the placement of the SFZ file. In other words, I needed to either miss off the first “/” or add “./” That probably explains the no sound part! D’oh!