Settings for Ardour 7.4 on Linux Mint 21.1?

I have installed Ardour from the run package on When I start Ardour I get this message:

WARNING: Your system has a limit for maximum amount of locked memory. This might cause Ardour to run out of memory before your system runs out of memory.

You can view the memory limit with ‘ulimit -l’, and it is normally controlled by /etc/security/limits.conf

All seems to be commented out in that file and I need some advise what to change.
The file they are referring to looks like this:

# /etc/security/limits.conf
#<domain>        <type>  <item>  <value>

#Each line describes a limit for a user in the form:
#<domain>        <type>  <item>  <value>
#<domain> can be:
#        - a user name
#        - a group name, with @group syntax
#        - the wildcard *, for default entry
#        - the wildcard %, can be also used with %group syntax,
#                 for maxlogin limit
#        - NOTE: group and wildcard limits are not applied to root.
#          To apply a limit to the root user, <domain> must be
#          the literal username root.
#<type> can have the two values:
#        - "soft" for enforcing the soft limits
#        - "hard" for enforcing hard limits
#<item> can be one of the following:
#        - core - limits the core file size (KB)
#        - data - max data size (KB)
#        - fsize - maximum filesize (KB)
#        - memlock - max locked-in-memory address space (KB)
#        - nofile - max number of open file descriptors
#        - rss - max resident set size (KB)
#        - stack - max stack size (KB)
#        - cpu - max CPU time (MIN)
#        - nproc - max number of processes
#        - as - address space limit (KB)
#        - maxlogins - max number of logins for this user
#        - maxsyslogins - max number of logins on the system
#        - priority - the priority to run user process with
#        - locks - max number of file locks the user can hold
#        - sigpending - max number of pending signals
#        - msgqueue - max memory used by POSIX message queues (bytes)
#        - nice - max nice priority allowed to raise to values: [-20, 19]
#        - rtprio - max realtime priority
#        - chroot - change root to directory (Debian-specific)
#<domain>      <type>  <item>         <value>

#*               soft    core            0
#root            hard    core            100000
#*               hard    rss             10000
#@student        hard    nproc           20
#@faculty        soft    nproc           20
#@faculty        hard    nproc           50
#ftp             hard    nproc           0
#ftp             -       chroot          /ftp
#@student        -       maxlogins       4

# End of file

EDIT- Use three back ticks to enclose preformatted text, makes it much easier to read:). -Seablade

Some info on a Ubuntu page for you

For what it’s worth though, I use Ardour 7.4 on Mint (LMDE, latest version) and I get that error each time I install / update Ardour and I ignore it and carry on as normal and have never had an issue :upside_down_face:

A lot of distributions now place individual configuration files in the /etc/security/limits.d directory.
In that directory on my machine I have a file named 95-jack.conf although other distributions may have audio or some other similar phrase in the name. I think the number at the beginning indicates the order they should be parsed, so that if there are any conflicting directives the highest numbered file will have precedence.

My files may be left over from older configurations which only enabled RT scheduling for jackd users, so you will likely need to check your limits.d directory to see if a likely looking file exists. The file should refer to the user group which should have permissions for RT scheduling on your machine. On my machine which was originally confgured several years ago, that user group is jackuser, but an audio user group is probably more likely on recent distributions.
In whatever file exists, or which you create, you can uncomment or add lines similar to these:
@jackuser - rtprio 95
@jackuser - memlock unlimited

You can also enable for one specific user, in which case you would use your username but no “@” character in the beginning.

On Debian based systems, I think you need to edit…


…instead of…


…and then add the lines:

@audio - rtprio 95
@audio - memlock unlimited

Afterwards, you will need to confirm your user is in the ‘audio’ group, and then logout/login.

I’ve recently installed Ardour and Mixbus on Linux Mint.

From my notes:

Added myself to the “audio” group in Administration – Users and Groups

Added the below to /etc/security/limits.conf just above #End of file

@audio - memlock unlimited
@audio - rtprio 99

Your limits.conf will now end like this:

#ftp             -       chroot          /ftp
#@student        -       maxlogins       4
@audio - memlock unlimited
@audio - rtprio 99
# End of file

Note: requires a restart to take effect.

Check in a terminal with:
ulimit -l
It should now display “unlimited”.

My core i7 laptop with 32GB of RAM was still struggling so you might need to adjust the performance settings if this is the case as below.

Using Synaptic download cpupower-gui (or if you prefer the non gui version called cpupower that’s run from a terminal).

Start cpupower-gui from a terminal or from the menu under Administration and select the “Performance” setting from the Governor dropdown and apply.

Set the Governor to performance each time you use Ardour (if your computer requires this).

After this everything runs perfectly on Linux Mint.

Good luck and let me know if you have any issues.


Thank you… that did the trick!
What is the normal DSP percentage with lets say 5 tracks of midi with surgeXT and Yoshimi and a few audio tracks with just compression and EQ? For me the DSP goes to 20-30% almost immediately with just one surgext and one Yoshimi and I have a rather high end computer with 32 GB Ram and a Ryzen 9 3900 CPU and SSD M2 disks.

For Mint 21 i spent a lot of time to get working with good performance. Maybe here are addtitonal useful things for you.

1 Like

On Mint my DSP was hitting 80-90% with Surge without setting the Governor to Performance as mentioned above. Around 30% is pretty much what I hit with a few audio tracks and a couple of synths. Some things like Decent Sampler and the new AI guitar amp emulation type plugins can be demanding and get me up over 50%. I’ll bounce down the tracks to rendered audio if it gets too out of hand. And incidentally, if you do use Decent Sampler the file open dialogue doesn’t work in the Ardour plugin. I had to load the sample packs in the standalone version which places them in the correct directory to be picked up by the plugin. Same issue with Proteus from Guitar ML. The Load Model button does nothing so you can’t load a model which makes the plugin useless. The developer suggested Ardour is blocking the pop up File Open type dialogue so there’s something going on in Ardour and Mixbus that’s preventing plugins from presenting it. Probably an issue for another thread. It’d be good to give Proteus a try.

Stefan, that is a great walk trough for setting up Linux Mint and Ardour! Thank you!

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.