Setting up master track output

Hi guys,

I spent a few days trying to make my MIDI controller work with Ardour and I have made significant progress, but I cannot get any sound output no matter what I try. I’m sure it must be something simple and stupid, but I don’t see it. Here are some screenshots of my settings:

https://1drv.ms/u/s!AhAK45tMbmCHiWAbxbzenHH54Pjl?e=01CKH1

MIDI keyboard > Audio+MIDI track in
Audio+MIDI out > Master track in
Master out > ???

Not sure what to do next, how do I setup the output of the Master track to be… what should it be? Sorry for the dumb questions.

There are a few screwy things going on in that last screenshot. For instance you don’t seem to have a tab under destinations that says ‘Hardware’ which you should have, and would let you route audio to the hardware output. Also your master bus seems a bit screwy IIRC as it should only have two outputs for most people, but going from 1-3 to 1 again is also odd. It is also odd that you have two screenshots that seem to show different system hardware (A1 and A2).

So I would suggest rebooting your computer, starting with a fresh session, import audio first and play back audio, make sure that works, then create your track, route audio into it, make sure that works, and audio out, then work with MIDI in a similar fashion.

  Seablade
1 Like

Chances are what you really want is a MIDI track, with MIDI from your controller in input and audio in output.
You will also need a MIDI plugin in your mixer strip. Ardour will default to general midi but you can use any synth / soundfount player…

1 Like

I didn’t see but @seablade is right, this is a little strange.

Appreciate the help, guys.

Where does the system hardware show in A2? I thought that was the MIDI keyboard source (which for some reason shows as “system”)?

I was wondering why there is no hardware destination tab… So there really should be one.

I got as far as importing audio and trying to play it back. No sound. I tried switching the input and output devices to the following (the only other option aside from generic x2), but no change.

https://1drv.ms/u/s!AhAK45tMbmCHiWaxxsFvQ4QLeyYN?e=ZQGZWb

Any tips on how to proceed with troubleshooting?

EDIT: Changing the output device to the one mentioned above also added a hardware tab in the destinations.
https://1drv.ms/u/s!AhAK45tMbmCHiWfuhnQ2ezEkSGEy?e=sZCWCZ

Err you caused me to panic for a moment when you said A2, I am assuming you are not actually on Ardour2 as you have things like the ALSA backend, which didn’t exist in A2 and neither did MIDI.

At the very least PLEASE make sure you are on an up to date version of Ardour. A2, as I mentioned I doubt you are actually on, is probably decadeS old at this point and I wouldn’t recommend ANYONE use it these days.

Ok the HDMI output is what it sounds like, you would be outputting over your HDMI connector, in most cases this is not what you want. You will probably want the Realtek output, but we need to determine why this is not working. First question does it work in any other software?

Seablade

How do I test if the Realtek output is working with other software? I usually use my MIDI keyboard with Jack and qSynth and it works fine for just playing. I wanted to get Ardour working in order to start recording as well.

Yes, it is the latest version of Ardour5.

About A2 I meant the screenshot name, which I assumed is what you meant as well.

Ahh ok, yea the shortcut way of describing the version of Ardour is also A# but you are correct that is just confusion in terminology. That being said A5 (Meaning Ardour v5) is also vastly out of date at this point and you should try with A6 (Meaning Ardour v6), but in this case I am not expecting to much of a difference. So download at least the free version from this website and use that for testing.

Lets start with something basic though, and just make sure we are all on the same page. What are the various devices that show up in the audio device lists on Audio/MIDI Setup? Please list all the options. Also the output of the command aplay -l when typed into a command line. You can surround the output with the CODE tag here and it will format readibly.

  Seablade

OK, installing Ardour 6.6 demo fixed the issue, apparently, whatever it was. I didn’t touch anything, didn’t have to even route any tracks, it just worked out of the box. There is now a proper hardware destination to which the master out is routed.
I’m never installing stuff from the Software Manager again…

I will go ahead and get the full version now. Thank you for the patience and help.

In case it’s needed:

Output from aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: Generic Analog [Generic Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

Audio/MIDI setup devices:
Input:

  • HD-Audio Generic

Output:

  • HD-Audio Generic
  • HDA ATI HDMI