Session seems to be broken

Hi,
I am using Ardour4 on Ubuntu16.04.
My session is often shutting down for no apparent reason, but I can generally recover my data.
But today it shut down and it seems to be broken : When I launch Ardour, it displays the list of my sessions, I can open them all except the last one, and below Sampling rate there is a “??”, and below File resolution a “_” sign. I could load the backups of my sessions, except the last one.
If you have any idea…
Thanks

Another information, the error message I get is "Session “/home/[location]” did not load successfully: Failed to load state

Hmm worrisome for a couple of reasons, but I have to start with the first disclaimer… Please upgrade your version of Ardour. There have been thousands of bugfixes since A4, it is likely you are running into an (Or rather multiple) issue that may have already been addressed.

That being said, if you download a demo version of A5 from this website, does it open your session?

If not can you post your session file (Ends in .ardour) somewhere that it can be taken a look at?

Seablade

I tried with the free version of Ardour 5 but got the same error message.
I put the .Ardour file on this link :


Thank you!

ERROR: XML error: Input is not proper UTF-8, indicate encoding !Bytes: 0xA0 0xDF 0xCC 0xB9 in Decalcyphe.ardour at line 289252:21

I’ve deleted that line (control surface setting, not directly related to the session), and the session loads. The fixed session file is: http://robin.linuxaudio.org/tmp/Decalcyphe.ardour

It looks like this session was using an ancient version of Ardour and this issue has meanwhile been fixed. Please update to 5.12

Yes it works! I will consider upgrading indeed.
Thank you very much

Aurel

Hi again,
I have the same problem as last time - right after I upgraded to 5.12, so it may be the last time, hopefully!
I can’t find in the the .ardour file the error Robin mentioned last time.
The new file is here
Thanks

Aurel

Same issue, again. line 298465 needs to be removed

--- a/Decalcyphe.ardour	2020-01-18 01:20:48.647145381 +0100
+++ b/Decalcyphe.ardour	2020-01-18 01:23:42.663803399 +0100
@@ -298462,7 +298462,6 @@
     <Protocol name="Generic MIDI" active="no"/>
     <Protocol name="Mackie" active="no"/>
     <Protocol name="Wiimote" active="no"/>
-    <Protocol name="䷯����:wCi9�u1����:G�" active="no"/>
     <Protocol name="Faderport" active="no"/>
   </ControlProtocols>
   <Extra>

Fixed file re-uploaded to the same URL: http://robin.linuxaudio.org/tmp/Decalcyphe.ardour

Thanks!

It works with the free version of Ardour 5.12 I previously downloaded.
But I tried to install the “full” version, uninstalled the previous version when I am invited to, and then realize that the free version is still running instead, when it gets mute after 10 min.

And also, when I start the session, I get this message telling me that I am going to be in trouble if I don’t play with /etc/security/limits.conf
This file says :

#* soft core 0
#root hard core 100000
#* hard rss 10000
#@student hard nproc 20
#@faculty soft nproc 20
#@faculty hard nproc 50
#ftp hard nproc 0
#ftp - chroot /ftp
#@student - maxlogins 4

Aurel

Check that you indeed ran the full version installer. A common issue is that the demo installer is still in in the download folder, and the full-version gets a (1) suffix.

As for the system-config, check perhaps /etc/security/limits.d/audio.conf (usually created when installing jack), but please start a new thread or look in the forum for similar issues. This is unrelated to the original issue here.