Session Error after sudden close

So this happened recently in Mixbus and I want to note here for info and helping people solve a problem that you might experience like this one.

My session in Mixbus had suddenly closed after saving and sitting idle 2 minutes. I had tried then to reopen and it shot an error message:

[ERROR]: XML error: invalid character in attribute value in /Volumes/store1/EOD/EOD_Mix/EOD_Mix.ardour.bak.ardour at line 231:19 [ERROR]: XML error: attributes construct error in /Volumes/store1/EOD/EOD_Mix/EOD_Mix.ardour.bak.ardour at line 231:19 [ERROR]: XML error: Couldn't find end of Start Tag Region line 231 in /Volumes/store1/EOD/EOD_Mix/EOD_Mix.ardour.bak.ardour at line 231:19 [ERROR]: XML error: PCDATA invalid Char value 5 in /Volumes/store1/EOD/EOD_Mix/EOD_Mix.ardour.bak.ardour at line 231:19

Turns there was a hidden crappy characters written to the main XML(ardour project file) on line 231.

Went to an online validator for XML got the same error.

I fixed this by locating the line with a good text editor and deleting the crap characters and resaving as the same name of course. Then I could open the project file just fine. This happened on Mixbus 3.7 FYI on MacOSX 10.11.6

Just in case you may think your project and work was for not you may be able to recover.

For what it is worth…

Here is what I corrected:
231: 19 An invalid XML character (Unicode: 0x5) was found in the value of attribute “name” and element is “Region”

I corrected:

Region name=“foot_steps_carpet.232

After the =” lay those nasty hidden characters."
Just deleted in an editor resaved and problem solved.

All hail plain text editable project files :slight_smile:

The question remains how that char came in there. Is this on an English system? Regions are usually named after tracks. Do any tracks have names with accents or non ASCII characters?
Do any plugins in the session speak a foreign language? (We’ve seen issues on OSX where a plugin changes the locale when it saves state, but hoped to have worked around this)

Ah good point!

  • First off it is in English. Boston MA.
  • Second after looking at the naming of the tracks all named with no accents and the like. Mac though does do stupid things like that. I was dragging the same region into track and it was creating copies as you see of the original region. Sooo… mabey somewhere in there it introduced a non viewable bad character to the xml.

Like you said I have seen Mac OSX do this on standard notepad like apps where it tries to make it look pretty. But in Ardour/Mixbus I assume you guys and gals account for it or do not do that.

But again it was only after a sudden crash for apparently no reason just sitting idle. Like it was introduced somehow then. I will keep monitoring this as I am doing foley and mixing on a short film. I will let you know if I see anything else. It was a blip and wanted to have a way for people to recover or have info towards that end.

Ardour does not do anything special and just uses UTF-8 chars. That’s also usually direct: What you type is delivered as-is.

Except in some cases where accessibility features and in some cases also auto-correct can intercept things. That’s usually baked in to the OS or window-manager and there is nothing we can do about it. e.g. cmd+space may bring up Spotlight on OSX rather than trigger Ardour’s stop+forget capture. option+alt+whatever can also produce non-standard key sequences; those are normally fine (UTF8), but if you know what you’re doing and purposely want to shoot yourself in the foot, Ardour/Mixbus will not stand in your way :slight_smile:

Anyway that does not seem to have been the case here.

One thing I could imagine: That file in question (foot_steps_carpet) was imported from some VFAT or NTFS external disk which uses some MS-Windows character set. Filename conversion went wrong and the periodic-backup-save (5 mins) after import triggered the problem. Usually [mac]OS[X] does convert those filenames correctly and “foot_steps_carpet” also looks innocuous.

If you stumble over this again or can reproduce it, please let us know. Thanks for sharing the solution, it may help others in case they encounter a similar issue.