Session created with different sample rate

I’m trying to export a mix and the resulting audio files are sped up, as if they were 44.1K files being played at 48K. I suspect this is because I created the session at a different sample rate than I ended up primarily using.
When I created the session I was running Jack at 48K. Shortly after that, I started running jack at 44.1 instead, and kept using the same session. I got the “If you load this session, audio may be played at the wrong sample rate” warning on startup, but all new audio that I recorded in after the change played back correctly in Ardour, and I didn’t end up using any of the clips I’d recorded in while running at 48K. (I cannot, at this point, remember why I didn’t just start a new session at that point, given that the older audio recordings wouldn’t have been compatible.)
Anyway, all the audio that’s now in the session was recorded after I started consistently running jack at 44.1, and it sounds normal from within Ardour. When I go to export the track, I’ve tried a couple different formats, including CD (RedBook) at 44.1, Ogg Vorbis at Session Rate, and AIFF at 48k. When I try playing these files back using mplayer, they are all sped up. The sample rate printouts at the top of mplayer are consistent with the formats I specified in Ardour, and one exported with “Session Rate” seems to be 48k.
Anyway, do you have any suggestions at this point for how to get this session exported with the same speed that I hear it in Ardour?

I realize that, as a workaround, I can for example use sox with “speed 0.91875” to fix the file after export. What I’m wondering is whether there might be a way to get Ardour to export with the desired speed, to avoid some conversions.
Also, I possibly should have mentioned setup details— I’m using Ardour 3.1 on Arch Linux (installed from Arch’s package manager).

I can only guess that Ardour “thinks” it still has to convert the sample rate to 44.1 kHz.

I would try opening the session file in a text editor and change “sample-rate=” to “44100”. That way you shouldn’t get the message at startup anymore and maybe export would work as expected, too.

Hi C.L.A.,
That method seems to have worked-- I don’t get the warning message, and exported audio plays back at the speed at which it was recorded, and played at within Ardour.

see this

its primarily the sample rate setup in the Ardour and Jack. use the cmd line tools to see what is the set sample rate.