Session crashing Ardour when loading

I’m fairly new to Ardour, but have really been enjoying it…until today :slight_smile:
Running 8.6 on Win 10.

I have a session that worked yesterday, but today freezes Ardour displaying a window that says “Please wait while Ardour loads visual data”. There’s a button with “OK” on it. Pushing it makes it go white.
Needless to say, Ardour never loads the visual data. Eventually I’ll get the windows prompt asking to close program or wait.

One thing that was different is when I saved it last, the transport was running. Not sure if that’s anything, but it was different than normal.

It’s a simple session with one audio track and two midi tracks driving Superior Drummer 2.3
There are a TON of changes to the grid on this session, though, using the grid tool.

I have tried renaming the auto generated session and history backup files to load, but they respond the same.

Any ideas on how to recover this?

First thing to try, does enabling [x] "Safe Mode: Disable all Plugins (checkbox in the Recent Session Dialog) help?

Next… delete the file instant.xml in the session folder (you can open the session folder by right-clicking on the session in the Recent Session Dialog, and selecting the path there).

That file saves zoom-level, playhead position (and window sizes etc). It can be removed safely. – In some rare cases the saved playhead position accidentally ends up many hours to the right at high zoom level, and the Ardour ends up calculating the grid for ages…

If neither helps, we need more information. Can you share the session (zip it up)? If you can only share it privately, that’s also an option.

Thanks for the suggestions, Robin. Unfortunately, neither solved the problem.
I can share a zip of the session, but would prefer to do so privately. The song doesn’t belong to me, I’m just doing some work on it. I’ve uploaded the session to my google drive, just need a way to get the link to you.

email → I’ll keep the material you send me confidential.