Session: cannot have two events of type TransportStateChange at the same sample

I’m getting the error message quoted in the title. Nothing seems to happen, only the log light blinking red prompts me to read those messages.

What does it mean? What is causing it and should I just ignore it or change some workflow?

Running Ardour 6.9 on Kubuntu Studio 20.04.

Please find a recipe (repeatable steps) to reproduce this, and then post a bug report at tracker.ardour.org.

It is not serious, but I believed I had fixed that issue before 6.9 was released.

I went to nightlies to fetch the debug version of Ardour 6.9 and downloaded Ardour-6.9.0-dbg-x86_64.run. When installing I am warned that

WARNING: GCC4/5 libstdc++ ABI Mismatch

Ardour was compiled with gcc4, your system uses a newer version of the
standard c++ library. Plugins on your system may not load or plugin-UIs
may cause crashes.

I didn’t get this warning while dealing with any of the 6.8-versions, nor with the 6.9 from the official download. There were some packages updated recently, but I don’t know how to tell when this particular package was last updated.

Should I just proceed anyway, or are there better paths to follow?

Not sure if I’m looking in the right place, but “apt show gcc” returns

Package: gcc
Version: 4:9.3.0-1ubuntu2

Not quite unexpected

That is for old systems with a libstc++4 (from gcc4, April 2015 or earlier). For systems since then with libstc++4 (from gcc5 or newer, like yours), you’d want Ardour-6.9.0-dbg-x86_64-gcc5.run, but as @ax11 mentioned it’s no longer available…

Anyway, a recipe how to trigger this issue, or a session that produces it would be useful.

Yeah, I’m doing my best to reproduce the error message, but unfortunately no success thus far…

But guys, why don’t you keep a debug version of the current release? I recommend you create one and make it available, especially now that nightlies are pre0 because of features not present in 6.9…

When having a similar problem with that same error I didn’t find this. I have the same error too but for me (in Windows) it appears to not finalize the midi region that I record while using jack sync.
link here to my related problem:

You can safely ignore it. This message basically means that Arodur’s GUI is asked twice to do the same work (at the same time).

In a nutshell, A Transport-State-Change event is what causes the Play button to turn green or gray, and various other UI displays are also updated.

Yes I can tell nothing bad happens, except that the recorded midi stays in a limbo state and I can’t keep it with jack enabled. There’s probably a workaround but with what I’ve tried I couldn’t get the recorded midi region to stay permanent. It would stay colored “red”, and would disappear after disengaging the recording. I’m thinking the transport state change is what’s not allowing that region to close properly (for lack of a better word). I’ll probably be able to narrow the problem down more.

That is an entirely different issue, unrelated to TransportStateChange events discussed here.