Selection not snapping to the bar accurately


Whenever I make a selection of audio or midi with ‘Snap’ on and set to ‘Bar’, it should be snapping the selection to the bar. The problem is, although it appears to do this, when I zoom in, it seems the selection is only approximately to the bar, not exactly. If I paste at the ‘Playhead’, again I have the same problem that it doesn’t snap exactly to the bar.

The end result of copying and pasting bars of music is that it all goes out of time due to these inaccuracies.

Currently I have no choice but to use a workaround whereby, for every selection and paste, I have to zoom all the way in to line up the timing, then zoom all the way back out again. This is the only way I can ensure my songs stay in time.

So the question is, am I doing something wrong or is this a bug? I’ve never had this problem with other DAWs, in fact I’m not sure I had this problem with earlier versions of Ardour.

I’m currently using Ardour v6.3.0 on Ubuntu.

Many thanks,


Please verify that in Preferences->Snap, you have enabled “Snap to Grid”. That is set by default. But if you’ve disabled it then you can snap to other stuff (region edges, etc) but not to the visible Grid.

Perhaps we need a little indicator between the Snap and Grid buttons, when Snap-to-grid is enabled.


Hi Ben,

Fantastic thanks, it works OK now!

Snap-to-grid was enabled. My problem was that I also had snap-to-markers enabled, and I have hundreds, maybe even thousands of location markers which weren’t visible that it was snapping to, as well as the grid.

I guess location markers get created automatically because I didn’t make them. Or maybe you can explain how they work. Or how I can remove them…

Thanks anyway for the speedy reply.


Please attach a screenshot. Location markers are not created automatically, but x-run markers are. If they are x-run markers, this is a sign of bad system configuration on your side, but also a bug on ours, because snap should never use x-run markers.

Hi Paul,

Yes they are xrun markers and they do get snapped to. Screenshot attached.

In what way is my system config bad?



xruns mean that your computer cannot keep up with the audio hardware. You should use a larger buffer size, and also consider other reasons why your system is misbehaving. You can read an overview here: The Ardour Manual

meanwhile, we’ll fix the snap-to-xrun marker.


Thanks very much for the help and information.

I guess my laptop is quite old. Maybe time for a new one…


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.